Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Skookum Robotics


Skookum Robotics Skookum Robotics SK-360 SK-540 & SK-720 Digital Flybar


Reply
 
Thread Tools Display Modes
Old 02-18-2012, 10:29 AM   #1
thefrog
Registered Users
 
Posts: 2,265
 

Join Date: Feb 2011
Location: Australia
Unhappy Logo 500SE maiden - and crash

I maidened my Logo today and it ended badly.

I've attached the log file - it doesn't show any obvious inputs or log entries, but there's something seriously funky about the data it contains, but more of that later.First off, about the build - this is a new build, new SK. Setup is:

Logo 500SE, Scorpion 4025-110, Hobby Wing 100A Pro, Align DS610s + DS650, Castle BEC Pro, Skookum SK720, DSMX Rx sats in DSM2 (1024) mode, DX7 Tx.

I noted a few weird things during the setup but couldn't figure them out. For example the D/R doesn't work correctly, when moving from normal to idle 1 it shouldn't change dual rate/expo, but it does. When spooling the heli up the throttle did nothing until mid stick and then kicked in. I set up the SK and then set the end points of the ESC. So I'm wondering if there's a comm issue between the Tx and SK. Remember I am using DSMX Rx sats (can't get DSM2 anymore) and they're set up as DSM2/1024 in the SK.

Now for the flight details. I fly with the self level off (bank 1) and on + invert in the second channel (bank 2). I tested the self level at 1:00 into the flight. The heli rolled left (you can see my right cyclic input in the log) and I switched it off. Thought I'd check it out later. I was flying in idle 1 at this point, just getting a feel for the heli. I flipped to idle 2 and all seemed ok. I gave it a collective pop (first one) and it climbed straight, then rolled left and I lost control and the heli took a dirt nap.

To be continued.. I need to explain the weirdness in the log.
Attached Files
File Type: zip LOG4.zip (736.3 KB, 91 views)

Last edited by thefrog; 02-19-2012 at 12:13 AM..
thefrog is online now        Reply With Quote
Old 02-18-2012, 11:21 AM   #2
thefrog
Registered Users
 
Posts: 2,265
Thread Starter Thread Starter
 

Join Date: Feb 2011
Location: Australia
Default Part 2 - funky log

Things I noted in the log as they came up:

Around 40 seconds the vibes drop to zero and the overall acceleration goes to 75m/s! This ends at around 60 seconds, around when I flipped on the self level. When I enabled self level the heli rolled left - you can see my corrective cyclic input.

The log also doesn't show the change in throttle position from idle 1 to idle 2. It works on the bench - you can see in the software how the throttle position changes. Also the headspeed doesn't change according to the log but it did in reality (2000 to 2200).

Around 77.7seconds the cyclic inputs go to zero and at 79 seconds the collective goes from +27% to -45%. It doesn't show my big collective input though. At 76 seconds the throttle goes to zero. The impact appears to be at 82 seconds but acceleration stays at 150m/s until 91 seconds.

These inputs don't make much sense to me. I don't think I hit hold and let go of the cyclic so it could hang in the air for 6 seconds before hitting the ground. Also, to hit the ground for 9 seconds also doesn't make sense.

I'm going to consider two things:

a) that the DSMX sats in DSM2/1024 mode aren't working.
b) the SK has some trouble receiving/processing imputs and outputs.

I will test the DSMX sats tonight by swapping the DSM2 units from my Kasama. I can't do much about the SK though - I await your feedback and will contact Skookum on Monday.

Sucks to be down after only a minute though.
thefrog is online now        Reply With Quote
Old 02-18-2012, 11:56 AM   #3
georgi UK
Registered Users
 
Posts: 10,032
 

Join Date: Mar 2007
Location: United Kingdom
Default

=] oh Froggy my weekend was going so well, sorry to see this news,

where do we start? the RF is solid, same for voltage, vibes are perfect. there is no mechanical fail warnings, in fact the event log shows there isn't one!

I think the first hint is at 10 secs in, the vibes zero and the accelerometers flat line, at close to 40 secs we see a heli with zero recordings for the gyro's but the playback continued, it revived itself at the 60 sec point where you bank switched, at the close to 80 sec part it drops out again.

you need to get this log to SK, and the unit would be my advice. please keep us posted and have a quiet beer or two on me





georgi.
__________________
georgi UK
georgi UK is online now        Reply With Quote
Old 02-18-2012, 12:19 PM   #4
thefrog
Registered Users
 
Posts: 2,265
Thread Starter Thread Starter
 

Join Date: Feb 2011
Location: Australia
Default

Quote:
Originally Posted by gmcallister View Post
=]
you need to get this log to SK, and the unit would be my advice. please keep us posted and have a quiet beer or two on me
I'm on the same page here - am doing a final test of the Rx sats (DSMX vs DSM2) to rule that out. As you said - the clues are there - flat line from accelerometers speaks volumes, and mechanically my build seemed good (working on Kasama has made me very aware of the importance of the build.. ).

Will send the log off to Skookum later this weekend, hopefully they can shed some light. Unfortunately it probably means close to a month without an SK - unless I buy another direct and ship this coming week (sounds expensive though).

So back to my Srimok beater tomorrow then.. could be worse hey..

EDIT: Tested DSM2 sats and it still doesn't do the D/R expo properly.

Last edited by thefrog; 02-18-2012 at 12:25 PM.. Reason: More info
thefrog is online now        Reply With Quote
Old 02-18-2012, 12:39 PM   #5
georgi UK
Registered Users
 
Posts: 10,032
 

Join Date: Mar 2007
Location: United Kingdom
Default

=] I'm sure SK will advise you to return the unit, and x-ship you a new one to speed things up maybe?

the RF looks good, in fact perfect from what I can tell. this would not cause abnormal accelerometer readings,

it could be something getting into the SK from an external source? needs SK tech on this!
__________________
georgi UK
georgi UK is online now        Reply With Quote
Old 02-18-2012, 04:16 PM   #6
Jamesppp
Registered Users
 
Posts: 2,084
 

Join Date: Feb 2008
Location: Carrollton,Georgia
Default

can you download the Skookum file reader software to view the files before buying the 720?
I want to put one on my Logo and have just started looking into it.
__________________
Compass7HV,Sk720HeliJive120HV Pyro 700 52L allHV
Outrage 550: Scorpion 4020-1390,CC125A ESC,WR ESC
Logo 5003D Scorpion Sk720 4020-1100, Blade130X MCPX
TT E-620 SE x 2: Scorpion 4025-740 200srx, nano qx JR Parkmites x 2
Jamesppp is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Skookum Robotics


Skookum Robotics Skookum Robotics SK-360 SK-540 & SK-720 Digital Flybar

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com