Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Car and Truck Info and Support > Electric > On-Road


On-Road On-Road


Reply
 
Thread Tools Display Modes
Old 09-06-2009, 12:32 PM   #1
cnelan
Registered Users
 

Join Date: Aug 2009
Location: maryland
Default propulse with belt cp motor

I felt like making my propulse that i traded for some trx 2.5 engine parts run on a brushless motor from a belt cp. i used a 30A heli speed control and a futaba ms (a 75mgz controler) but the speed control wouldn't turn the motor on (I wasn't doing any throttle). Then I tried a blade cx2 receiver and controller and it worked with that. its hard to drive it with the cx2 controller so i was wondering if some controllers don't work with brushless motors?
cnelan is offline        Reply With Quote
Old 09-08-2009, 12:38 PM   #2
cnelan
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2009
Location: maryland
Default fixed

I fixed the problem (it was a bad radio system). I raced the brushless propulse against my rustler xl-5 upgraded with : xl-10, 10 turn 540 motor (speed gem), carbon fiber/aluminum a arm, ground assault wheels, wheelie bar, hpi radio, 8.4v battery, and stiff springs. the rustler won by 3 feet.
cnelan is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Car and Truck Info and Support > Electric > On-Road


On-Road On-Road

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com