Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Hitec Radios > Hitec Gyro/Servos


Hitec Gyro/Servos Hitec Gyro and Servo Support


Reply
 
Thread Tools Display Modes
Old 03-15-2012, 12:47 PM   #1
GreyEyes
Registered Users
 

Join Date: Nov 2011
Location: FL
Default HSG-5084MG Lasted 3 minutes

I have a Trex 450 Sport V2 that was fitted with the stock Align servos, DS410M's and DS420. It has always had a slight tail wag that I could not get rid of. It was small enough that I just put up with it and had 100+ flights on it. As my flying started get more aggressive I started getting a bit of tail blowout with rapid pitch increases. The little wag I could tolerate, but this I could not.

I upgraded to a Hitec HSG-5084MG.

When I lifted off for the first time I was overjoyed, no wag!

The joy did not last long.

I was in a low hover, 5' or so just trying to get the feel of it to see if the tail felt any different when after 2 minutes I lost all tail response. This resulted in a spiraling crash that fortunately only resulted in a slightly bent tail boom.

After replacing the boom I did not trust the heli, so I put my training gear on and spooled up until it got light on the gear. I proceeded to test the tail out, rotating back and forth in both HH and rate mode. After about a minute, I again lost tail control.

Now the servo is completely dead, no movement or sound at all. Tried bypassing the gyro thinking maybe it had crapped out, no response.

Put the Align DS420 back on, heli flies just like before.

When I purchased the HSG-5084MG for the tail I also bought 3 HS-5065MG's to someday upgrade the cyclics. Now I am afraid to even think about trying them.
__________________
Trex 450 Pro V2
Trex 450 Sport V2
Esky Belt CPX
Blade mCP X
GreyEyes is offline        Reply With Quote
Old 03-15-2012, 02:29 PM   #2
newbheliusr
Registered Users
 
Posts: 6,813
 

Join Date: Apr 2011
Location: Mountlake Terrace, Wa
Default

That servo has a 2 year warranty. Send it in and they'll fix/replace it.
newbheliusr is offline        Reply With Quote
Old 03-15-2012, 02:32 PM   #3
A.T.
Registered Users
 

Join Date: Jul 2008
Location: Auckland NZ
Default

Quote:
Originally Posted by GreyEyes View Post
I have a Trex 450 Sport V2 that was fitted with the stock Align servos, DS410M's and DS420. It has always had a slight tail wag that I could not get rid of. It was small enough that I just put up with it and had 100+ flights on it. As my flying started get more aggressive I started getting a bit of tail blowout with rapid pitch increases. The little wag I could tolerate, but this I could not.
I upgraded to a Hitec HSG-5084MG.
When I lifted off for the first time I was overjoyed, no wag!
The joy did not last long.
I was in a low hover, 5' or so just trying to get the feel of it to see if the tail felt any different when after 2 minutes I lost all tail response. This resulted in a spiraling crash that fortunately only resulted in a slightly bent tail boom.
After replacing the boom I did not trust the heli, so I put my training gear on and spooled up until it got light on the gear. I proceeded to test the tail out, rotating back and forth in both HH and rate mode. After about a minute, I again lost tail control.
Now the servo is completely dead, no movement or sound at all. Tried bypassing the gyro thinking maybe it had crapped out, no response.
Put the Align DS420 back on, heli flies just like before.
When I purchased the HSG-5084MG for the tail I also bought 3 HS-5065MG's to someday upgrade the cyclics. Now I am afraid to even think about trying them.
There is always a simple reason why any servo burns out so quickly.
Suggest reason is isolated and corrected so as to enhance your future flying pleasure.

Digital Servo - Burnout. Cause & Prevention and more under sub Sections
"Glitches & Jitter in Receiver, Servo & ESC - causes and cures "
"Servo - Digital & Brushless Servo, Programmers and Software"
below
"Radio Systems, Accessories, Alterations and FAQ." at:
Alan's Hobby, Model & RC FAQ Web Links

Alan T.
A.T. is offline        Reply With Quote
Old 03-15-2012, 02:48 PM   #4
GreyEyes
Registered Users
Thread Starter Thread Starter
 

Join Date: Nov 2011
Location: FL
Default

Quote:
Originally Posted by newbheliusr View Post
That servo has a 2 year warranty. Send it in and they'll fix/replace it.
Yeah, just printed out the return label, scares me to try another one though, or the ones for the cyclic. I was lucky this time with minimal damage and the warranty doesn't cover the damage to the rest of the heli.

Quote:
Originally Posted by A.T. View Post
There is always a simple reason why any servo burns out so quickly.

Yeah, one of them being a bad servo.

Mounting is flat, linkage is smooth, operating within specs, cheaper servo functions flawlessly (just not quite fast enough), never got warm or buzzed, just quit.

Pretty much points to bad servo.
__________________
Trex 450 Pro V2
Trex 450 Sport V2
Esky Belt CPX
Blade mCP X
GreyEyes is offline        Reply With Quote
Old 03-15-2012, 08:17 PM   #5
minititinflyer
Registered Users
 
Posts: 1,621
 

Join Date: Dec 2007
Location: hollywood fl
Default

if your tail binds or your make bind as u move it about then it can burn out
__________________
blade msr!, blade mcpx! ,blade 130x!, trex 250!, ,mini titan e325 v2! ,gaui hurricane 425e! ,trex 600 esp!, trex 700e! ,Hitec Aurora 9!, spektrum dx6i!
ikon! quark! !AMA# 1021263!
minititinflyer is offline        Reply With Quote
Old 03-15-2012, 08:23 PM   #6
GreyEyes
Registered Users
Thread Starter Thread Starter
 

Join Date: Nov 2011
Location: FL
Default

Quote:
Originally Posted by minititinflyer View Post
if your tail binds or your make bind as u move it about then it can burn out
Quote:
Originally Posted by GreyEyes View Post
linkage is smooth
already pointed this out, there is no binding and other servo works fine
__________________
Trex 450 Pro V2
Trex 450 Sport V2
Esky Belt CPX
Blade mCP X
GreyEyes is offline        Reply With Quote
Old 03-15-2012, 11:37 PM   #7
minititinflyer
Registered Users
 
Posts: 1,621
 

Join Date: Dec 2007
Location: hollywood fl
Default

do you keep it hh al the time even when you on it and turn it every now and then bc that would make that happen too i got the servo on my 250 never had problem make sure your set your gyro to work with it too right hz and all and volts
__________________
blade msr!, blade mcpx! ,blade 130x!, trex 250!, ,mini titan e325 v2! ,gaui hurricane 425e! ,trex 600 esp!, trex 700e! ,Hitec Aurora 9!, spektrum dx6i!
ikon! quark! !AMA# 1021263!
minititinflyer is offline        Reply With Quote
Old 04-30-2012, 05:08 PM   #8
GreyEyes
Registered Users
Thread Starter Thread Starter
 

Join Date: Nov 2011
Location: FL
Default

Follow up on this.

Sent to Hitec, they said it had a bad trace (a defect on the printed circuit board). They replaced the whole servo with a new one rather than repair the old one. New one installed and now have 20+ flights on it without problems.

Haven't tried the 65's on the cyclic yet, but I am slowly gaining confidence that I just had the misfortune to get a bad servo, and to Hitec's credit they do stand behind their products.
GreyEyes is offline        Reply With Quote
Old 04-30-2012, 05:28 PM   #9
AtTheCross
Registered Users
 
My HF Map location
Join Date: Dec 2008
Location: Southern CA
Default

what gyro? I know that it says digital on the HSG-5084MG the but when i used it with my gy401 i had to use it in analog because it was overheating. many in the funcopter forum on another site has seen this as well and confirmed with HiTech that it should be used with the hitech gyro or in analog mode
__________________
1 Corinthians 1:18 For the message of the cross is foolishness to those who are perishing, but to us who are being saved it is the power of God.
AtTheCross is offline        Reply With Quote
Old 05-01-2012, 06:20 AM   #10
wanderer56
Registered Users
 
Posts: 4,005
 
My HF Map location
Join Date: Oct 2009
Location: Lafayette, LA., USA
Default

I'm using that servo with a Spartan Quark @ 6V with no problems. 5084 doesn't even get warm. When I had the GY48V gyro, I did have to run it in analog mode. Must be the gyro's compatable frame rate with certain servo's. Quark has an adjustable setting for that. Mine is 1520/333.

When the 5084 first came out, there was a problem with them burning out when used @ 6V, but mine has been flawless for over 2 years. Not even a broken gear!

Also using 5065MG's on cyclic @ 6V with no problems. Also not even a broken gear in over 2 years.

Can you tell I'm a Hitec man?
__________________
Trex 500-3226-1600, 14T, Koby 90LV, HS-5245MG, DS655, AR7200BX, DFC
Trex 450 Sport-2221-8, 15T, CC Edge 50 Lite, HS-5065MG, HSG-5084MG, AR7200BX, DFC
DX8
wanderer56 is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Hitec Radios > Hitec Gyro/Servos


Hitec Gyro/Servos Hitec Gyro and Servo Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com