Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Futaba Radios and Electronics > Futaba 14MZ - 12Z


Futaba 14MZ - 12Z Futaba 14MZ and 12Z Help and features Support Forum


Reply
 
Thread Tools Display Modes
Old 05-28-2012, 05:32 PM   #1
Bernierj
Registered Users
 

Join Date: Mar 2012
Location: France
Default BUG on T14MZ

Hello everyone,

I was flying with my Raptor 90 this afternoon and my T14 decided to stop working.
During the flight and without touching the screen or any switch button, the TX started to BIP and switched to a different model in memory (another heli I used yesterday)

It displayed the screen asking if you want to start broadcasting and Futaba logo was orange and flashing

Obviously my Raptor cashed because I was not able to control it anymore, but failsafe module worked perfectly and saved my engine...

I've been using this TX for 3 years almost every weekend (when the weather allows us to fly) without any problem.

Does anyone have any feedback about that?
I can remember having read some problems with memory card, the TX was reseting when using pictures/sounds from it?

Thanks,
Jonathan

Last edited by Bernierj; 05-29-2012 at 04:32 AM..
Bernierj is offline        Reply With Quote
Old 05-29-2012, 09:09 AM   #2
Phaedrus
Registered Users
 
Posts: 1,115
 
My HF Map location
Join Date: Aug 2005
Location: SOCAL - USA
Default

I used my 14MZ for 7 years and never had an issue with pictures or sounds stored on the CF card being used while flying. I do not recall ever hearing about such issues either. I also have never heard of this particular issue either.

I suggest you send the TX to your nearest service center to be looked over.
__________________
AMA Leader Member
Team Futaba
Raptor 90SE/YS91ST - T550E FB - T550E FBL w/CGY-750
Phaedrus is offline        Reply With Quote
Old 05-30-2012, 04:50 AM   #3
Bernierj
Registered Users
Thread Starter Thread Starter
 

Join Date: Mar 2012
Location: France
Default

Thanks for answer.
I found the root cause of my issue... my CF card seems to be broken.

I've tried to read it on my computer with a card reader and I hardly managed to open it.
When I finally get the mem card detected I tried to copy/paste some files but it failed.

I tried to use my card reader with others mem card and no problem...
Bernierj is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Futaba Radios and Electronics > Futaba 14MZ - 12Z


Futaba 14MZ - 12Z Futaba 14MZ and 12Z Help and features Support Forum

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com