Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Miniature Aircraft Helicopters > MA Glow


MA Glow Miniature Aircraft Glow Helicopter Support Forum


Reply
 
Thread Tools Display Modes
Old 09-26-2012, 04:54 PM   #1
rcflyerheli
Registered Users
 
Posts: 1,615
 

Join Date: Apr 2010
Location: Granbury
Default Swash issues

This is my first setup on a Fury 55 (or any MA heli) and I see something I've not seen on any Align, Gaui or SAB setup.

This heli is being set up with the new Vbar Silver. The setup has gone smoothly as has all my previous Vbar setups. I have set 12.5 degrees collective and the required 8 degrees of cyclic. With these values, I am getting the swash to hit its end of travel ability when the collective is at mid stick once the setup mode is complete.

There is a noticeable click on the elevator servo and it is visibly straining to get to its full travel position when backwasrds cyclic is given at the midstick position. At either full up or down collective it doesn't hit the limit of the swash. All of the Vbar parameters (endpoint, subtrim, collective and cyclic values) are good.

It doesn't bind during either the collective or cyclic step during setup. I've read that the Vbar will use different throws during flight that are not the same as those used for the setup, but my concern is that it will try to over drive the swash in the air like I am seeing on the bench.

This will be setup as a sport flyer, with relatively tame agility values. I don't see that it will do any hard 3D type of maneuvers, so am I being overly concerned?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Goblin 700, Vbar - Trex 700 V2, Vbar - Trex 700DFC, Vbar - Gaui X7, Vbar - Logo 600SX, Vbar Mini
Trex600EFL Pro, Vbar - Trex 600 ESP, Vbar - Trex 500 ESP, SK 720 - DJI 550, Naza GPS
rcflyerheli is offline        Reply With Quote
Old 01-29-2013, 06:15 AM   #2
super
Registered Users
 

Join Date: Feb 2011
Location: UK
Default Re: Swash issues

Getting this same issue with my Furion 6 using a 3GX.
Can't understand how anyone gets more than 7.5 deg cyclic movement in all directions, as the swash hits the main shaft. Very odd.
Might try a different swash on it and see how I get on.

Cheers


John
super is online now        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Miniature Aircraft Helicopters > MA Glow


MA Glow Miniature Aircraft Glow Helicopter Support Forum

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com