Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Batteries and Charging Support > Brand Specific Charger and Battery Support


Brand Specific Charger and Battery Support Brand Specific Charger and Battery Support


Reply
 
Thread Tools Display Modes
Old 11-11-2012, 06:24 PM   #1
steeleagle
Registered Users
 

Join Date: Feb 2012
Location: Vancouver, BC Canada
Default iCharger 106B "Connection Breakdown" error

I keep getting this message when I attempt to charge. Have tried 3S, 2S, and 1S batteries individually and with a parallel charge board with no luck - the message comes up as soon as I press start/enter to start the charge cycle. The manual says it means an interuption between the battery and the charging source during the charge cycle. Any idea how to clear the error?
steeleagle is offline        Reply With Quote
Old 11-11-2012, 08:47 PM   #2
propxprt
Registered Users
 

Join Date: Mar 2012
Location: Wisconsin
Default

Maybe try a different power supply or battery?
propxprt is offline        Reply With Quote
Old 11-12-2012, 02:08 PM   #3
steeleagle
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2012
Location: Vancouver, BC Canada
Default

Good suggestion. Tried it but no joy! Trying to get hold of tech support at Progressive RC.
steeleagle is offline        Reply With Quote
Old 12-02-2012, 01:27 PM   #4
turko
Registered Users
 

Join Date: Sep 2009
Location: new westminster,B.C. canada
Default connection breakdown

I had a similar thing happen and it turns out my charge lead had a short in it, bought a new lead and problem solved.
__________________
Blade 300 CFX, nano cpx , mcpx bl, dx6i,blade 450 3d
turko is offline        Reply With Quote
Old 12-10-2012, 12:38 AM   #5
Jaguar_5
Registered Users
 
Posts: 796
 
My HF Map location
Join Date: Dec 2008
Location: Seattle
Default

Quote:
Originally Posted by steeleagle View Post
Good suggestion. Tried it but no joy! Trying to get hold of tech support at Progressive RC.
Did you ever get this figured out?
If not just let me know!
__________________
LAHeli - Mikado - Henseleit - FASST
Powered by ProgressiveRC & Spyder Batteries
Jaguar_5 is offline        Reply With Quote
Old 02-14-2013, 09:52 AM   #6
steeleagle
Registered Users
Thread Starter Thread Starter
 

Join Date: Feb 2012
Location: Vancouver, BC Canada
Default iCharger 106B "Connection Breakdown" error

No I didn't get it sorted out. Progressive RC replaced the unit but the second one did the same thing. I think it is getting a spike when I turn on the power supply - I have it hooked up in the sequence shown in the manual. Any ideas?
steeleagle is offline        Reply With Quote
Old 02-14-2013, 08:20 PM   #7
cyclo
Registered Users
 
Posts: 2,852
 

Join Date: Jul 2012
Location: Toronto, Canada
Default

Your power supply most likely has an issue.
__________________
2 x Compass 7HVU Scorpion HK-4525-520, YGE 160HV, MKS HBL950/980, AR7200BX
Compass Atom 5.5 YGE 90HV, MKS 9660A+/BLS980, AR7200BX
Compass Atom 500 Castle ICE75, Savox 1250MG/1290MG, AR7200BX
Gaui X3 Scorpion HK-2520-1580, HW50A V3, KST 215/515, AR7200BX
Hoverthings FLIP-FPV
cyclo is online now        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Batteries and Charging Support > Brand Specific Charger and Battery Support


Brand Specific Charger and Battery Support Brand Specific Charger and Battery Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com