Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > nano CP X Brushless Mods


nano CP X Brushless Mods Blade nano CP X Brushless Mods Information and Help


Reply
 
Thread Tools Display Modes
Old 12-16-2012, 05:40 PM   #1
Miracle Boy
Registered Users
 
Posts: 826
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Question TBO with new BL mild build - Help please!!

Hi guys,

O.K. so today I finished my first BL build. Everything went fine apart from the RKH swashplate, but that's another story.

I took my 1st Nano which was flying fine prior to going BL with it and installed the mild kit. it's flying o.k. but the tail used to hold just fine on pitch pumps, but now it doesn't. It kicks out 20 % or so and changing the throttle cure (flat) doesn't seem to cure the problem. Looking tail in, the tail kicks to the right with even minimal increases in pitch.

I'm running throttle at 65% in Normal, and 70% in IU on a DX6i. Pitch curve of 10% - 90% on both normal and IU.

The mesh with the main gear to motor pinion is not tight, I'm fairly confident that my soldering is fine, I solder as part of my job, so all joints are nice and shiney. Oh, and I'm using E-Flight 150mAh stock batteries, and they all work perfectly well with a stock Nano.

I've tried a new tail rotor, no difference at all, tried 75% on throttle, still the same, tried bending the pins slightly on the tail motor connector in case of poor connection, still the same.

What else should I try, I'm all out

Thanks!!
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-16-2012, 06:01 PM   #2
gilligansc
Registered Users
 
Posts: 406
 
My HF Map location
Join Date: Aug 2010
Location: USA,North Carolina, Southport
Default

make sure the 3-1 screws are tight?
just a thought.
__________________
Align 500 ESP AR7200Bx,Align 250 SE/DFC AR7200Bx, B400, Nano BL!
gilligansc is offline        Reply With Quote
Old 12-16-2012, 06:10 PM   #3
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

And all thoughts are appreciated, but 3 in 1 screws are tight. I'll go and re-do mt motor wires and see if that helps.

Thanks
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-16-2012, 07:42 PM   #4
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

Re-soldered motor wires and fitted a new tail rotor out the packet. Still the same, possibly worse?? WTF!!
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-17-2012, 05:38 AM   #5
NCcraig
Registered Users
 
Posts: 9,188
 

Join Date: Mar 2011
Location: North Carolina
Default

This will help. Read the explaination for what is happening to your heli. About half way down under "Tail Mix".

http://www.helifreak.com/showthread.php?t=412147
__________________
Team Newb pilot
Trex 450 Pro V2 (KDE450XF motor,iKON),Trex 500 ESP (KDE500XF motor, iKON), Witespy HT450, NQX, DX9, AMA# 966513.
NCcraig is offline        Reply With Quote
Old 12-17-2012, 07:54 AM   #6
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

Hey Craig,

Thanks for the link mate

I've only really scanned the tail mix section, of DoubleCH's excellent document, but basically, I seems I need to try running a V throttle cure with the ESC in Gov Arm mode. Is that correct. I'll need to have a look at how to use my TX to change the programme mode in the ESC.

To be totally honest, I'm a little scared of starting messing with the settings of the ESC.

I've had a good look at my Heli and although I has some minor vibes, they seem quite within acceptable limits to me. I'd like to try and find a mechanical solution to the problem if I can, do you think that running a slightly longer boom and/or a the KBDD tail rotor might help resolve this issue. Also, I used 26AWG wire for the power wires to the ESC, do you think that changing these to 24AWG wire might help. I know Dylan recommends using 24AWG wire, but I only have 22AWG wire and 26AGW and the insulatation on the 22AGW wire kept melting when I made a kink in it, so I gave in and used the 26AGW wire instead.

Thanks again!!!
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-17-2012, 08:50 AM   #7
bmc76
Registered Users
 
Posts: 1,647
 

Join Date: Nov 2012
Location: Houston Tx
Default

Minor vibes was the reason for my tbo, along with a lot of other people on here who told me that was what my problem was. After I fixed that, I switched the esc to gov arm mode and the tail hold is incredible. If you have minor vibes I would get rid of them before trying anything else. Mine would go crazy on minor pitch changes, ended up changing the main shaft which looked fine, blade grips, and rebalanced the blades. It should run perfectly smooth in your hand. If you get it to run smooth you should not have any tail issues.

I've tried 4 different sizes of tail booms starting in 5mm increments over stock, stock length worked the best for me.
__________________
Gaui X3-SK-540 | Gaui X2- Beastx | 250 Pro DFC |130X 3S ZYX-S | 300X | DX8 | Real Flight 6.5
Lynx Heli Innovations Team Pilot
bmc76 is offline        Reply With Quote
Old 12-17-2012, 11:47 AM   #8
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

Thanks bmc76,

It seems I have a lot of reading to do to try and fully understand the BLheli (ESC) set up procedure for both Gov TX and Goc Arm modes. From what I've read (and what I THINK I understand), the best option for me would be to run in "Setup mode", but I need a tool stick for that and I don't have one at present, and I'd need to add a connector onto the ESC like Dylan did and is shown in the install instructions for the BL kit on the AD website.

First things first, I need to fix my vibes issues. I've bought the Xtreme blade balancer and the magnetic base, but I'll need to modify that as out the box the balance shaft is too long and is tight between the magnets, so that's not gonna work. LOL!!

I noticed that the large blade fixing screws on the balancer are to large to fit the Nano's blades, and the small screws are too small to fit the Nano blades corectly. How to you guys solve that problem? a little bit of shrink wrap on the small screws to "fill" the holes in the Nano blade root??

I'm assuming I should balance the blades with some scotch magic tape, like ppl do with the 130X tail blades??

Many thanks for your help and advice guys
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-17-2012, 11:58 AM   #9
bmc76
Registered Users
 
Posts: 1,647
 

Join Date: Nov 2012
Location: Houston Tx
Default

I just used a little piece of blue painters tape, put it on one blade and spooled it up in my hand, if it felt worse I put it on the other blade. Once it feels better I move it up and down on the blade until I'm satifsfied. Takes all of 10 minutes if that.

You can use your TX to switch to gov arm mode, just enter program mode, listen for the correct tones, select with the throttle stick and your done. Once you're in program mode you might want to let it cycle through functions a few times without selecting anything so you get used to hearing the tone pattern. Reread the program instructions a few times, and make sure you are looking at the correct version of the instructions. I had to unplug my tail motor so I could here the tones. I believe v9 was 2 long tones and 2 short tones for gov arm mode, once you hear it you move the throttle stick to 0 to select it.
__________________
Gaui X3-SK-540 | Gaui X2- Beastx | 250 Pro DFC |130X 3S ZYX-S | 300X | DX8 | Real Flight 6.5
Lynx Heli Innovations Team Pilot
bmc76 is offline        Reply With Quote
Old 12-17-2012, 05:07 PM   #10
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

O.K. thanks mate I've still got those vibes to try and resolve, and I've now discovered that my my tail boom must be fractured somewhere as the tail motor twists far too easily.

I'm going to make a new solid boom, but where can I get hold of some of that tiny heatshrink that blade use on the magnet wire for the tail motor? I've already tried ordering what I thought was 0.8mm OD unshrunk heatshrink, only to discover that's the shrunken ID of the stuff I bought.

I think I understand the Programming sequence for Gov Arm mode, I think it should be 3 long, low beeps, followed by 2 short high beeps, once it cycles to there, drop the throttle stick and then set up a 0-20-20-20-X throttle curve where X = the target head speed, but then I get confused..... How do I set up a V curve with that? I must be missing something

NC Craig,

If your still following this thread, can I ask please, Where did you get that nice yellow wire I saw that you'd used on your nano tail? I think I read a while back that you used the wire from an old parallel printer cable? Or maybe it was a USB cable?

Thanks again guys for your help!!
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-17-2012, 05:19 PM   #11
bmc76
Registered Users
 
Posts: 1,647
 

Join Date: Nov 2012
Location: Houston Tx
Default

0,20,20,20,x is in normal mode to arm the esc. Set your v curve in idle up mode.
__________________
Gaui X3-SK-540 | Gaui X2- Beastx | 250 Pro DFC |130X 3S ZYX-S | 300X | DX8 | Real Flight 6.5
Lynx Heli Innovations Team Pilot
bmc76 is offline        Reply With Quote
Old 12-17-2012, 06:08 PM   #12
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

Quote:
Originally Posted by bmc76 View Post
0,20,20,20,x is in normal mode to arm the esc. Set your v curve in idle up mode.
Ah, Right!! that makes sense now, DOH!! And in theory if I arm it as 0-15-15-15- X, that will mean that any throttle increase above 15% of target will be ignored, or is 20% the min value for this setting. Of course I understand that anything above or bellow that target setting in my V curve would be ignored? Right?

Sorry, I'm just trying to get my head around all this stuff LOL!!

Thanks again!!
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-17-2012, 10:32 PM   #13
bmc76
Registered Users
 
Posts: 1,647
 

Join Date: Nov 2012
Location: Houston Tx
Default

Quote:
Originally Posted by Miracle Boy View Post
Ah, Right!! that makes sense now, DOH!! And in theory if I arm it as 0-15-15-15- X, that will mean that any throttle increase above 15% of target will be ignored, or is 20% the min value for this setting. Of course I understand that anything above or bellow that target setting in my V curve would be ignored? Right?

Sorry, I'm just trying to get my head around all this stuff LOL!!

Thanks again!!

20% is the min, your main motor will ignore stick inputs as long as your v curve in iu doesn't fall below 20%, your v curve applies only to the tail. Below 20% triggers spooldown. Doesn't matter what your middle values are in normal as long as min is 0, max is whatever % of throttle you want, all values inbetweeen need to be greater than 20%.
__________________
Gaui X3-SK-540 | Gaui X2- Beastx | 250 Pro DFC |130X 3S ZYX-S | 300X | DX8 | Real Flight 6.5
Lynx Heli Innovations Team Pilot
bmc76 is offline        Reply With Quote
Old 12-18-2012, 07:53 AM   #14
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

O.K. thanks bmc76, muc h appreciated!!
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-21-2012, 10:02 AM   #15
Miracle Boy
Registered Users
 
Posts: 826
Thread Starter Thread Starter
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

Hi guys,

O.K., So now I have to admit that I've been a complete dumb ass

As mentioned previously, I found that I have a cracked tail boom as the tail twists too easily. I was having another look at that when I discoverd that the tail boom had never been pressed home fully from the day I bought it and took it out the box. I have never touched that tail boom and I didn't remove it while fitting the BL kit.

As you'll all know, you can tell if the boom has moved by looking at the little kink in the magnet wires as they exit the frame and are bent back towards the 3 in 1 unit. That little kink was where it's always been out the box. but I decided to try and make sure it was pressed in properly and to my surprise it went in about another 4 - 5 mm

The tail always held fine with stock motor, so I didn't think to question it.

I put in a freshly charged pack and at 68% flat throttle I was still seeing a bit of tail kick, but not as bad as before. I bumped the throttle up to 72% and the tail kick is gone!!! And that's still with the cracked tail boom in place!!


Thanks for your help guys, I'll try gove arm mode next and see how it goes with that.
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > nano CP X Brushless Mods


nano CP X Brushless Mods Blade nano CP X Brushless Mods Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com