Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Skookum Robotics


Skookum Robotics Skookum Robotics SK-360 SK-540 & SK-720 Digital Flybar


Reply
 
Thread Tools Display Modes
Old 12-20-2012, 10:14 PM   #1
j.avant
Registered Users
 
Posts: 223
 

Join Date: Sep 2011
Location: USA, TX.
Default Any New Revisions On The SK540

My heli has been setting for a few months so I'm wondering if there is any new updates for the 540? I think i have 3.15 now.

John
j.avant is offline        Reply With Quote
Old 12-20-2012, 11:10 PM   #2
demon1300
Registered Users
 

Join Date: Jul 2012
Location: Albury/Wodonga, AUS
Default

Not trying to be nasty or anything but don't you think maybe going here would have answered your question

http://www.skookumrobotics.com/updates/
__________________
Beater Helis - MCPX BL & TREX 450 Pro DFC
Warp 360 - SK540, MKS DS92A+ / DS95i, YEP45
TREX 550 DFC v3 - SK540, Radix V2 554's
Goblin 700 - HPS, 4530-500, SK720 & GPS, MKS HBL 950's/980, ICE2 160HV
demon1300 is online now        Reply With Quote
Old 12-21-2012, 04:13 AM   #3
thefrog
Registered Users
 
Posts: 2,152
 

Join Date: Feb 2011
Location: Australia
Default

Nope, nothing yet.
thefrog is offline        Reply With Quote
Old 12-21-2012, 08:19 AM   #4
j.avant
Registered Users
 
Posts: 223
Thread Starter Thread Starter
 

Join Date: Sep 2011
Location: USA, TX.
Default

Quote:
Originally Posted by demon1300 View Post
Not trying to be nasty or anything but don't you think maybe going here would have answered your question

http://www.skookumrobotics.com/updates/

Probably would have. But there may be some new info on the 540 that Mr. Georgi would know about. That's why i like asking here. Like the change in the mounting foam/pad/tape.

Thanks though.

John
j.avant is offline        Reply With Quote
Old 12-21-2012, 08:21 AM   #5
j.avant
Registered Users
 
Posts: 223
Thread Starter Thread Starter
 

Join Date: Sep 2011
Location: USA, TX.
Default

Quote:
Originally Posted by thefrog View Post
Nope, nothing yet.
Thanks @ thefrog.

John
j.avant is offline        Reply With Quote
Old 12-21-2012, 10:57 AM   #6
RC Mike
Registered Users
 

Join Date: Sep 2010
Location: Illinois, USA
Default

Quote:
Originally Posted by j.avant View Post
My heli has been setting for a few months so I'm wondering if there is any new updates for the 540? I think i have 3.15 now.

John
The only complaint I have with the current version is that the EP governor could be better.
 
Skookum takes a year plus to get an update out. I think that they only have one guy doing firmware for all their products. Last was August 2011 so it will probably be next summer.
 
 
.
RC Mike is offline        Reply With Quote
Old 12-21-2012, 11:56 AM   #7
georgi UK
Registered Users
 
Posts: 9,187
 

Join Date: Mar 2007
Location: United Kingdom
Default

=] John, it's all about the gps release currently, the 540 is working magnificently, just needs the odd tweak here and there.

anything specific on your mind?
__________________
georgi UK
georgi UK is offline        Reply With Quote
Old 12-22-2012, 10:12 PM   #8
j.avant
Registered Users
 
Posts: 223
Thread Starter Thread Starter
 

Join Date: Sep 2011
Location: USA, TX.
Default

Quote:
Originally Posted by georgi UK View Post
=] John, it's all about the gps release currently, the 540 is working magnificently, just needs the odd tweak here and there.

anything specific on your mind?

Georgi.....My heli set for a few months. I took it out the other day and i have a head wobble now, that i didn't have when i set it up. I'm hopping that the dampners are the problem, don't really know.

When i took it out the other day i had a problem with one of the servos not working after initialization. I had to reinitialize the 540 again to get it to work. Any thoughts?

Thanks, John
j.avant is offline        Reply With Quote
Old 12-23-2012, 09:08 AM   #9
georgi UK
Registered Users
 
Posts: 9,187
 

Join Date: Mar 2007
Location: United Kingdom
Default

Quote:
Originally Posted by j.avant View Post
Georgi.....My heli set for a few months. I took it out the other day and i have a head wobble now, that i didn't have when i set it up. I'm hopping that the dampners are the problem, don't really know.

When i took it out the other day i had a problem with one of the servos not working after initialization. I had to reinitialize the 540 again to get it to work. Any thoughts?

Thanks, John
=] John, dampers deformed deteriorated? I have had a dead tail servo at initialize which worked fine after a re-boot, hook up to the pc and check the live data for peace of mind!
__________________
georgi UK
georgi UK is offline        Reply With Quote
Old 12-23-2012, 11:43 AM   #10
j.avant
Registered Users
 
Posts: 223
Thread Starter Thread Starter
 

Join Date: Sep 2011
Location: USA, TX.
Default Thanks again.

Quote:
Originally Posted by georgi UK View Post
=] John, dampers deformed deteriorated? I have had a dead tail servo at initialize which worked fine after a re-boot, hook up to the pc and check the live data for peace of mind!
I have some new dampers coming. That's what i thought, dampers.

I wasn't to concerned about the servo, all cyclic's are new.

Thanks Georgi.

John
j.avant is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Skookum Robotics


Skookum Robotics Skookum Robotics SK-360 SK-540 & SK-720 Digital Flybar

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com