Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > nano CP X Brushless Mods


nano CP X Brushless Mods Blade nano CP X Brushless Mods Information and Help


Reply
 
Thread Tools Display Modes
Old 12-17-2012, 12:41 PM   #1
bmc76
Registered Users
 
Posts: 2,600
 

Join Date: Nov 2012
Location: Houston Tx
Default Always something!!

I've had a good 50 issue free flights from my nano over the last couple of weeks, but I noticed a while back that the nano would pitch up from a stable hover with no input. I thought maybe it was the governer increasing rpm's, but it seems like it has been getting worse. I decided to pull the servos to inspect and clean them and ended up pulling one of the damn plugs off the board! I was being careful, at least I thought I was.

I'll get it fixed up, but just wondering if anyone is having that issue with the bird suddenly climbing from a stable hover. The pitch servo looks fine but the aileron has some bent sweepers facing inward, wondering if that's the issue.
__________________
Gaui X5-MiniVbar | Gaui X3-MiniVbar | Gaui X2 SK-540 | 250 Pro DFC |130X 3S GY280 | 300X-Ikon | DX8 | Real Flight 6.5
Lynx Heli Innovations Team Pilot
bmc76 is offline        Reply With Quote
Old 12-17-2012, 06:12 PM   #2
Miracle Boy
Registered Users
 
Posts: 1,307
 

Join Date: Apr 2012
Location: Scotland, United Kingdom
Default

Sorry to hear about your connector woes man I just gently wiggle mine off with tweezers, but I'll try to hold the connector to the board while I do that from now on.

Hope you get it sorted soon!!
__________________
Blade mSR / Blade mSRX / Blade mCPXv2 / Blade 4003D (not brave enough to fly it yet!!)
Miracle Boy is offline        Reply With Quote
Old 12-20-2012, 04:12 PM   #3
bmc76
Registered Users
 
Posts: 2,600
Thread Starter Thread Starter
 

Join Date: Nov 2012
Location: Houston Tx
Default

Figured out why it was pitching up and down, I must have inadvertently selected the first parameter on the p gain while in program mode. The governor was taking longer to adjust head speed. Set it back to default and it's fine. Fixed the plug, man those contacts are tiny, my eyes are still sore from straining to see them.
__________________
Gaui X5-MiniVbar | Gaui X3-MiniVbar | Gaui X2 SK-540 | 250 Pro DFC |130X 3S GY280 | 300X-Ikon | DX8 | Real Flight 6.5
Lynx Heli Innovations Team Pilot
bmc76 is offline        Reply With Quote
Old 12-20-2012, 04:26 PM   #4
NCcraig
Registered Users
 
Posts: 9,719
 

Join Date: Mar 2011
Location: North Carolina
Default

Quote:
Originally Posted by bmc76 View Post
Figured out why it was pitching up and down, I must have inadvertently selected the first parameter on the p gain while in program mode. The governor was taking longer to adjust head speed. Set it back to default and it's fine. Fixed the plug, man those contacts are tiny, my eyes are still sore from straining to see them.
You will be happier setting your I and P gains to 2.00. Also a 5 diopter, lighted magnifying glass will relieve that eye strain.

Sent from my DROID RAZR using Tapatalk 2
__________________
Team Newb pilot
Trex 450 Pro V2 (KDE450XF motor,iKON), Witespy HT450 (In the process of a H frame swap), Blade 200QX with FPV set-up, DX9, AMA# 966513.
NCcraig is offline        Reply With Quote
Old 12-21-2012, 06:42 AM   #5
mixfisto
Registered Users
 

Join Date: Feb 2012
Location: los angeles
Default

Craig, I just bought a used BL nano that you built. First I gotta say great work...flies great!

I looked on the HF BLheli thread, but there are over 200 pages of threads in there and would take ages to go through them.

Do you know where I can find a chart or instructions to program the esc?

Thanks
mixfisto is offline        Reply With Quote
Old 12-21-2012, 07:36 AM   #6
Lu523
Registered Users
 
Posts: 1,245
 
My HF Map location
Join Date: Sep 2012
Location: Covington GA
Default

http://astroid-designs.myshopify.com...ashing-service

You should find what you need there.
Lu523 is offline        Reply With Quote
Old 12-21-2012, 07:49 AM   #7
NCcraig
Registered Users
 
Posts: 9,719
 

Join Date: Mar 2011
Location: North Carolina
Default

Quote:
Originally Posted by mixfisto View Post
Craig, I just bought a used BL nano that you built. First I gotta say great work...flies great!

I looked on the HF BLheli thread, but there are over 200 pages of threads in there and would take ages to go through them.

Do you know where I can find a chart or instructions to program the esc?

Thanks
The link Lu523 gave to Dylans' site will help you. Also, I flashed that heli with version 9.2 of the BLHeli code.

By the way, you got a smokin' deal on the Nano.
__________________
Team Newb pilot
Trex 450 Pro V2 (KDE450XF motor,iKON), Witespy HT450 (In the process of a H frame swap), Blade 200QX with FPV set-up, DX9, AMA# 966513.
NCcraig is offline        Reply With Quote
Old 12-21-2012, 01:03 PM   #8
mixfisto
Registered Users
 

Join Date: Feb 2012
Location: los angeles
Default

Thanks guys!

Btw, I'm thinking of raising the p-gain and i-gain 1 step. It feels like the governor should kick in a tiny bit faster than it does.

I'm guessing most are using the default settings. have any of you adjusted the settings...and if so, to what?

Thanks

(btw - have the mild kit... and yes Craig, happy about the deal I got )
mixfisto is offline        Reply With Quote
Old 12-21-2012, 01:10 PM   #9
NCcraig
Registered Users
 
Posts: 9,719
 

Join Date: Mar 2011
Location: North Carolina
Default

Quote:
Originally Posted by mixfisto View Post
Thanks guys!

Btw, I'm thinking of raising the p-gain and i-gain 1 step. It feels like the governor should kick in a tiny bit faster than it does.

I'm guessing most are using the default settings. have any of you adjusted the settings...and if so, to what?

Thanks

(btw - have the mild kit... and yes Craig, happy about the deal I got )
Your gain settings are already to 2.0. That is two steps above default 1.0.
__________________
Team Newb pilot
Trex 450 Pro V2 (KDE450XF motor,iKON), Witespy HT450 (In the process of a H frame swap), Blade 200QX with FPV set-up, DX9, AMA# 966513.
NCcraig is offline        Reply With Quote
Old 12-21-2012, 01:12 PM   #10
bmc76
Registered Users
 
Posts: 2,600
Thread Starter Thread Starter
 

Join Date: Nov 2012
Location: Houston Tx
Default

Quote:
Originally Posted by mixfisto View Post
Thanks guys!

Btw, I'm thinking of raising the p-gain and i-gain 1 step. It feels like the governor should kick in a tiny bit faster than it does.

I'm guessing most are using the default settings. have any of you adjusted the settings...and if so, to what?

Thanks

(btw - have the mild kit... and yes Craig, happy about the deal I got )
I just raised my p and i gains to 2.0 ( 2 steps over default) following Craig's advice, governor is definitely faster. I switched to gov arm mode a while back, that is the way to go imo.
__________________
Gaui X5-MiniVbar | Gaui X3-MiniVbar | Gaui X2 SK-540 | 250 Pro DFC |130X 3S GY280 | 300X-Ikon | DX8 | Real Flight 6.5
Lynx Heli Innovations Team Pilot
bmc76 is offline        Reply With Quote
Old 12-21-2012, 01:14 PM   #11
mixfisto
Registered Users
 

Join Date: Feb 2012
Location: los angeles
Default

Quote:
Originally Posted by NCcraig View Post
Your gain settings are already to 2.0. That is two steps above default.
Hmmm... I'm wondering if I just need to get used to the feel of the bl nano vs my hp05 mcpx (been flying nano stock for about a month).

I'll live with this for a week or so and see if I can get familiar with it. If not, then maybe I'll try bumping the gains a bit.
mixfisto is offline        Reply With Quote
Old 12-21-2012, 01:14 PM   #12
NCcraig
Registered Users
 
Posts: 9,719
 

Join Date: Mar 2011
Location: North Carolina
Default

Quote:
Originally Posted by bmc76 View Post
I just raised my p and i gains to 2.0 ( 2 steps over default) following Craig's advice, governor is definitely faster. I switched to gov arm mode a while back, that is the way to go imo.
It's not advice. It is what I programmed into his ESC.
__________________
Team Newb pilot
Trex 450 Pro V2 (KDE450XF motor,iKON), Witespy HT450 (In the process of a H frame swap), Blade 200QX with FPV set-up, DX9, AMA# 966513.
NCcraig is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Blade Helicopters (eFlite) > nano CP X Brushless Mods


nano CP X Brushless Mods Blade nano CP X Brushless Mods Information and Help

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com