Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Batteries and Charging Support > Brand Specific Charger and Battery Support


Brand Specific Charger and Battery Support Brand Specific Charger and Battery Support


Reply
 
Thread Tools Display Modes
Old 11-05-2011, 10:10 AM   #1
superrmario
Registered Users
 
Posts: 429
 

Join Date: Jun 2011
Location: NJ
Default Just an FYI regarding Hyperion 1420i

Thought i would pass this along to my fellow fliers.

We all know the inherent dangers of batteries. Some are less prone to catch fire, and some if not monitored and treated correctly will cause extensive damage which some have unfortunately experienced first hand.

I purchased a Hyperion 1420i due to the need to charge my Lipos. It has all the features needed, PC interface to check battery health and the such. Not to.mention its a very powerfull charger @550 watts giving me 6amps when charging two 6s packs in series for my compass.

About 2 months ago my tx pack for my 10c needed charging. I have charged it before and had a saved program set for .7amp / 1c charge rate. Around 8 minutes later after the charge began it was finished. I though that maybe it errored out so i walk.over and sure enough it put 500+ mah back in. With that, i check the log on my pc software and it charged the pack at 9amps!! After i almost fell over from disbelief, i picked up the pack and it was red hot. I pick the pack up, put it into a lipo sack and place it into my freezer to cool.

Few days later i bring it back to my LHS and they contact their supplier. Said supplier states we will send you another one, we have seen this issue before. With that said they send a new one, i test it and it works fine.

Fast forward to last week. I charge my tx pack again, as i kick off the charge it pops up with a immediate 4+ amp blast and continues to climb to 8amp before i disconnect it.

It only seems happen on smaller packs such as a 700mah 9.6v tx pack or a 7.4v 2600 lion.

The supplier is sending me a charger, but i asked for a 720i dual port and will pay the difference.

I am not posting this to air Hyperion out, but posting this as a heads up to anyone that has this charger to please be careful!


Sent from my Droid Charge using Tapatalk.
superrmario is offline        Reply With Quote
Old 11-05-2011, 01:42 PM   #2
The WoodCrafter
Registered Users
 

Join Date: Jan 2010
Location: Westminster, California
Default

So you set the charger to charge at .70AMPS and it wanted to charge at 9AMPS?

Is it a problem with running a saved program or it just doesn't like low current charging?

That is scary.
The WoodCrafter is offline        Reply With Quote
Old 11-05-2011, 07:54 PM   #3
superrmario
Registered Users
 
Posts: 429
Thread Starter Thread Starter
 

Join Date: Jun 2011
Location: NJ
Default

Quote:
Originally Posted by The WoodCrafter View Post
So you set the charger to charge at .70AMPS and it wanted to charge at 9AMPS?

Is it a problem with running a saved program or it just doesn't like low current charging?

That is scary.
Yes... I set the charge rate on the NiCad to .7am (7 tenths of an amp), and it proceeded to charge it at more then 10 times that rate @ 9amp. It has done this on a NiCad, liIon as well as a Lipo.

It is not the fact of running a saved program, as it happens even on a random setup that i make.

What i do notice is the fact that it happens on "low voltage packs". For instance an 8s 9.6v 700mah NiCad, 2s 7.4v 1300mah Lipo or a 2s 7.4v 2600 liIon.

I can charge 6s 22.2v 2600mah lipo as well as two 6s in series @ 44.4v 3300mah pack with absolutely no problem.

Yes, it is scary as the first time i didnt catch it. Had it caught fire it would have been a big problem.

Sent from my Droid Charge using Tapatalk.
superrmario is offline        Reply With Quote
Old 11-07-2011, 12:08 PM   #4
Kiba
Registered Users
 

Join Date: May 2009
Location: CA
Default

Does this happen only when using the PC software or does it also happen when not connected to the PC and creating a charge profile using only the buttons on the charger?

I've noticed that the Hyperion PC software and USB interface chipset doesn't seem to have very robust (if any) error checking/correction and if there is any "noise" from your power supply then sending data from the PC to the charger can lead to incorrect settings on the charger.

I've noticed this particularly when using converted PC power supplies to power the charger compared to using a battery or lab/bench power supplies.

If I send my saved charging profiles from the PC to the charger when powering the charger with converted server power supplies I can count on at least 1 or 2 charging profiles appearing incorrectly on the charger. However, if I power the charger from a 12V battery or lab power supply when transferring settings from the PC to the charger then everything transfers correctly to the charger.
__________________
Minicopter Diabolo - HC3SX, Kosmik 200, Jlog 2.6, Quantum 4530, 12S, BLS255HV/BLS256HV
Bergen Magnum 44 - HC3SX, Wren MW44 turbine, BLS156HV/BLS256HV
Jeti DC-16
Kiba is offline        Reply With Quote
Old 11-07-2011, 01:23 PM   #5
superrmario
Registered Users
 
Posts: 429
Thread Starter Thread Starter
 

Join Date: Jun 2011
Location: NJ
Default

Quote:
Originally Posted by Kiba
Does this happen only when using the PC software or does it also happen when not connected to the PC and creating a charge profile using only the buttons on the charger?

I've noticed that the Hyperion PC software and USB interface chipset doesn't seem to have very robust (if any) error checking/correction and if there is any "noise" from your power supply then sending data from the PC to the charger can lead to incorrect settings on the charger.

I've noticed this particularly when using converted PC power supplies to power the charger compared to using a battery or lab/bench power supplies.

If I send my saved charging profiles from the PC to the charger when powering the charger with converted server power supplies I can count on at least 1 or 2 charging profiles appearing incorrectly on the charger. However, if I power the charger from a 12V battery or lab power supply when transferring settings from the PC to the charger then everything transfers correctly to the charger.
Unfortunate that this isn't the case. It fails whether am using the PC Software or no PC right off my car battery.

I have noticed that if you use two different Hyperion chargers with the same PC interface on the same computer, it will not display the different charge profiles per charger. It just list them in numerical order. I had to install the drivers and app and reinstall them to recognize the new charger after i send the old one back the first time.

What i am most concerned about is NOT (my inconvenience). It is more that the manufacture is aware of the issue and is still sending botched chargers on hardware device that is critical to safety.

If anyone is interested, i have refreshed the firmware and it didn't fix the issue.

Sent from my Droid Charge using Tapatalk.
superrmario is offline        Reply With Quote
Old 11-09-2011, 09:49 AM   #6
superrmario
Registered Users
 
Posts: 429
Thread Starter Thread Starter
 

Join Date: Jun 2011
Location: NJ
Default

As an FYI, my charger no longer powers up. I heard a pop while charging a 12s pack and assume it was the on board fuse.

Sent from my Droid Charge using Tapatalk.
superrmario is offline        Reply With Quote
Old 11-09-2011, 10:06 AM   #7
The WoodCrafter
Registered Users
 

Join Date: Jan 2010
Location: Westminster, California
Default

Bummer.

Well now you know it needs repair.
The WoodCrafter is offline        Reply With Quote
Old 12-09-2011, 08:37 PM   #8
sebo
Registered Users
 

Join Date: Jan 2011
Location: CT
Default

wonder if this is the reason the price is $129 at allerc.. probably discontinuing it due to widespread problems. hyperion is overpriced considering the amount of problems i've read.
sebo is offline        Reply With Quote
Old 12-09-2011, 08:44 PM   #9
The WoodCrafter
Registered Users
 

Join Date: Jan 2010
Location: Westminster, California
Default

Quote:
Originally Posted by sebo View Post
. probably discontinuing it due to widespread problems. hyperion is overpriced considering the amount of problems i've read.
Lot of posts in the Charger Forum with problems right now.

I hear they have a screwy storage setting and the percentage of charge thing they have going on is always way off.

I don't know about this charger.
I don't see this many problems for other brands.
The WoodCrafter is offline        Reply With Quote
Old 12-10-2011, 01:00 AM   #10
superrmario
Registered Users
 
Posts: 429
Thread Starter Thread Starter
 

Join Date: Jun 2011
Location: NJ
Default

Quote:
Originally Posted by sebo View Post
wonder if this is the reason the price is $129 at allerc.. probably discontinuing it due to widespread problems. hyperion is overpriced considering the amount of problems i've read.
Probably... I went though 2 of them. After the second charger broke, i asked for a 720 instead, and paid the difference. The 720 has the same exact interface and allows sync charging. I can fully utilize my 24v PS now.



Sent from my Droid Charge using Tapatalk.
superrmario is offline        Reply With Quote
Old 12-10-2011, 02:08 AM   #11
MrMel
V-BAR Guru
 
Posts: 13,571
 

Join Date: Apr 2005
Location: Lidingo/Stockholm, Sweden
Default

Quote:
Lot of posts in the Charger Forum with problems right now.
Or its because i went through and answered many posts, including old ones

Topic starter; can you replicate this, shoot me a pm with exact steps
Is it via pc or charger? Which FW and PC version?
I honestly have never seen that one before, I own several 1420 which i use for testing.
__________________
Gone fishing.. or hunting or something..

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MrMel is offline        Reply With Quote
Old 12-18-2011, 08:39 AM   #12
brewer00psd
Registered Users
 
Posts: 404
 

Join Date: Sep 2011
Location: danville, ohio
Default

I used a buddies 7/20duo 2 weeks ago to charge 2500 mah 9.6 TX battery. It is using a single 12 volt PS for power. I set up the unit for 1C charge and turned it on. About 30 seconds later the charger turned off(stopped charging and went to the home screen) without playing the done charging tone. I went through the setup and turned it on again. I came back a few (maybe 2-3) minutes later to hold and look at my brand new 9503 while the battery charged. When I picked it up the battery cover was hot to touch. I pulled the cover and the battery was so hot I could not hold it. I immediately turned off the charger, pulled the battery and threw it outside. It surprised me and I did not look to see what rate it was charging before I shut it off. My buddy gave me he'll for charging at the wrong rate, but when we went back to the charger all the settings were where I had set them and were correct. We chalked it up to an odd user caused issue. Now I read this and am wandering if I had the same thing happen? I have the same duo as my buddy. We will both be watching our chargers till we figure this out.
Matt


Sent from my DROIDX using Tapatalk
brewer00psd is online now        Reply With Quote
Old 08-30-2012, 04:00 AM   #13
Duesi
Registered Users
 

Join Date: May 2008
Location: Switzerland
Default

I have 2 Hyperion 1420i NET.
On one of them the 40A Fuse dies when i just connect a 2S Lipo Pack.
The Same Charger charges my 12S 5000mAh Packs without any Problem.

My LHS didnt't have replacement in Stock for now.
So i live with that for the Moment.
Duesi is offline        Reply With Quote
Old 12-21-2012, 12:20 PM   #14
Duesi
Registered Users
 

Join Date: May 2008
Location: Switzerland
Default

I got my Charger back from Hyperion Europe via my LHS...It was internally disassembled. They didnt't replace the Fuse or fixed it.
I just put a new Fuse in. Charger is now working now like before. I will use it for 12/14S only. Very crappy Service I would say

Gesendet von meinem HTC Desire HD mit Tapatalk 2
Duesi is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Batteries and Charging Support > Brand Specific Charger and Battery Support


Brand Specific Charger and Battery Support Brand Specific Charger and Battery Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com