Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 150 Class Electric Helicopters


150 Class Electric Helicopters 150 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
Thread Tools Display Modes
Old 12-27-2016, 07:40 PM   #1
GenericGuy
Registered Users
 

Join Date: May 2015
Location: North Florida
Default Trex 150X Configuration Lost

Hello,

I have a new Align Trex 150X. After configuring and saving via APP, the Trex150X does not respond to the transmitter.

I performed the following:

Upgraded 150 GRS firmware to version 1.1.1

Reconnect battery and bind Spectrum DX6i transmitter to Spectrum DSMX satellite (solid light),
Calibrate stick travel including throttle,
Set parameter to beginner,
Save configuration setting on 150 GRS APP,
Save and confirm configuration on APP,
The Trex 150X moves the swash down-up-down, emits 2 beeps and responds to DX6i transmitter controls as expected (GRS 150 light is aqua flashing).

Here’s the problem: If I disconnect and reconnect the the Trex 150 X battery with the transmitter power on, the Trex 150X emits 3 beeps and GRS flashes red/blue. It does not respond to transmitter controls. The satellite LED is sold.

Work around: Launch the iPhone APP and connect to the Trex 150X via Bluetooth, then move the transmitter throttle stick save and disconnect the APP. The Trex 150X responds to the transmitter as expected.

What am I doing wrong? Is the Trex 150X defective?

Transmitter: Spektrum DX6i
Satellite Receiver: Spektrum 9645 DSMX
iPhone 6s running 150 GRS APP: 1.1
Firmware version: 150GRS_v1.1.1.grs
GenericGuy is offline        Reply With Quote
Old 12-28-2016, 09:50 PM   #2
cm930
Registered Users
 

Join Date: Jun 2014
Location: Taiwan
Default

Quote:
Originally Posted by GenericGuy View Post
Hello,

I have a new Align Trex 150X. After configuring and saving via APP, the Trex150X does not respond to the transmitter.

I performed the following:

Upgraded 150 GRS firmware to version 1.1.1
.....
Does this happen to firmware v1.0.2? Could you revert to v.1.0.2 and try?

When I upgraded from v1.0.2 to v.1.1.1, I also found that sometimes my configuration got lost:
1) One time the heli did not respond to the transmitter, and I found the configuration had changed to DSM2 sat instead of DSMX sat.
2) Heli responded really slowly to stick input. Found configuration had changed to beginner mode instead of expert mode.

So I changed back to v1.0.2 and both of the above problems disappeared.
cm930 is offline        Reply With Quote
Old 12-29-2016, 12:34 AM   #3
starryalley
Registered Users
 

Join Date: Nov 2012
Location: Taiwan
Default

I'm using DX6i with 150X.

Also try turning on throttle hold beginning at 10% in the throttle curve setting in DX6i. Try increasing or decreasing it a little bit once a time and see if 150X starts successfully. Mine should be at 11% or 150X won't start at all. This is on both V1.0.2 and V1.1.1 for me.
starryalley is offline        Reply With Quote
Old 12-31-2016, 01:22 PM   #4
GenericGuy
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2015
Location: North Florida
Default

Quote:
Originally Posted by cm930 View Post
Does this happen to firmware v1.0.2? Could you revert to v.1.0.2 and try?

When I upgraded from v1.0.2 to v.1.1.1, I also found that sometimes my configuration got lost:
1) One time the heli did not respond to the transmitter, and I found the configuration had changed to DSM2 sat instead of DSMX sat.
2) Heli responded really slowly to stick input. Found configuration had changed to beginner mode instead of expert mode.

So I changed back to v1.0.2 and both of the above problems disappeared.
I rolled back to v1.0.2 and observed the same issue. Thanks for the suggestion.
GenericGuy is offline        Reply With Quote
Old 12-31-2016, 01:30 PM   #5
GenericGuy
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2015
Location: North Florida
Default

Quote:
Originally Posted by starryalley View Post
I'm using DX6i with 150X.

Also try turning on throttle hold beginning at 10% in the throttle curve setting in DX6i. Try increasing or decreasing it a little bit once a time and see if 150X starts successfully. Mine should be at 11% or 150X won't start at all. This is on both V1.0.2 and V1.1.1 for me.
I tested this solution by setting throttle hold between -10 and +15. Unfortunately the GRS150 failed to respond to the transmitter (flashing red-blue), the satellite receiver light was glowing solid.

Thanks for the suggestion.
GenericGuy is offline        Reply With Quote
Old 01-16-2017, 01:57 PM   #6
joanpeca
Registered Users
 
Posts: 365
 

Join Date: Jan 2013
Location: Seville, Spain
Default

I'm having the same problem with FUTABA S-FHSS. First it gave up responding to rudder and aileron channel. Then I tried to rebind, and now I'm not able to bind to the transmitter again (flashing red-blue). Did you find any solution to this issue?
__________________
ALZRC TRex 450 Pro DFC
ALIGN TRex 500 ESP DFC
ALIGN TRex 600E PRO DFC (Power booster)
Goblin 500
joanpeca is offline        Reply With Quote
Old 01-16-2017, 09:13 PM   #7
GenericGuy
Registered Users
Thread Starter Thread Starter
 

Join Date: May 2015
Location: North Florida
Default

Quote:
Originally Posted by joanpeca View Post
I'm having the same problem with FUTABA S-FHSS. First it gave up responding to rudder and aileron channel. Then I tried to rebind, and now I'm not able to bind to the transmitter again (flashing red-blue). Did you find any solution to this issue?
I contacted my retailer for support. After all attempts failed, the retailer agreed to replace the 150X. I just shipped the 150X to the retailer Saturday, 1/14/2017. It may take a couple weeks to get a replacement. I'll update HF concerning the replacement.
GenericGuy is offline        Reply With Quote
Old 01-17-2017, 06:12 AM   #8
joanpeca
Registered Users
 
Posts: 365
 

Join Date: Jan 2013
Location: Seville, Spain
Default

I'm afraid I'll have to do the same. Succeeded in rebinding again but still no activity in aileron channel (rudder came to life again).

I'll keep you updated.
__________________
ALZRC TRex 450 Pro DFC
ALIGN TRex 500 ESP DFC
ALIGN TRex 600E PRO DFC (Power booster)
Goblin 500
joanpeca is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 150 Class Electric Helicopters


150 Class Electric Helicopters 150 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2016 by RCGroups.com, LLC except where otherwise indicated. The HeliFreak.com logo is a trademark of RCGroups.com, LLC.