Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Simulators Support > Phoenix Flight Sim


Phoenix Flight Sim Phoenix Flight Sim


Reply
 
Thread Tools Display Modes
Old 12-07-2014, 04:12 PM   #221
ArchmageAU
HF Support
 
Posts: 4,444
 
My HF Map location
Join Date: Jan 2013
Location: Australia, Vic, Melbourne East
Default

Quote:
Originally Posted by dwahid View Post
I've had the Phoenix sim for several years and gave not been able to set it up correctly with a spektrum dx9. The problem is I'm always in idol up mode no matter what I try to do. I have calibrated several times and I'm not able to solve this. Can anyone please pm instructions or provide me with a contact number that I can call to sort this. I've tried tro call horizon hobby several times with no help.
You need to turn the governor off on models you want to use normal curve.

Even though the original post was for Phoenix 3, it still holds today.

Quote:
Originally Posted by TheBum View Post
...
Now you can go to work on the sim model. Try to select a "3D" or "intermediate" variant of the model because a lot of the setup will already be done for you. The following are the important things to make sure are set up in the sim (not in the radio):
  • The throttle, pitch, aileron, and elevator curves should be set up to be linear and expos should be turned off:
    System>Your controls, click on your TX, click on Edit, and click on the button in the Curve column
  • The idle-up and throttle hold functions should be turned off and remain off:
    System>Your controls, click on your TX, click on Edit, and select "Unmapped" in the Input column next to Throttle Hold and Idle Up
  • The collective pitch range should be set up to be symmetrical around zero pitch and to suited to your tastes (e.g. +11 and -11):
    Model>Edit, click on Detailed if running Phoenix 3, click on Main Rotor, and edit the Minimum pitch, Mid pitch (set to 0.0), and Maximum pitch
  • Optionally, if you want to use the throttle curves with no governing, turn off the governor:
    Uncheck the "Rotor governor enabled" option. Location of option:
    Phoenix 2.x: Model>Edit, click on Main Rotor.
    Phoenix 3: Model>Edit, click on Detailed, open the Rotor governor menu.
....
__________________
TRex 700E Pro DFC HV (BD3SX) - Gaui X5 (6S/BD3SX), Blade 130X, RealFlight, Heli-X, Taranis+DSMX
ArchmageAU is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Simulators Support > Phoenix Flight Sim


Phoenix Flight Sim Phoenix Flight Sim

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com