Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Skookum Robotics


Skookum Robotics Skookum Robotics SK-360 SK-540 & SK-720 Digital Flybar


Reply
 
Thread Tools Display Modes
Old 01-15-2011, 11:30 PM   #1
boltor
Registered Users
 

Join Date: Dec 2007
Location: Australia
Default Flashing red light on landing (ERROR: AUTO RESET)

After 2 successful flights earlier today, the 3rd flight ended in a rather large "lurch" down and right (which I recovered from), and then on landing, the discovery of a red flashing light on the SK720. The UI said "ERROR: AUTO RESET". The SK720 manual also indicates that a voltage error may have been the cause.

Below is the ESC flight log - of interest is the throttle input spike late in the flight (same time as the flight issue) at around 1445 s. I have a new DX8, but I doubt that this was the cause (I have had no issues so far).



Also attached is the SK720 log. Just the vibration issue (that I am already aware of).

Any pointers on what to look for? Could poor batteries cause this (a voltage issue)? Reason I mention the batteries is the 3rd flight had my oldest batteries (but I would be a little surprised if they were already on the way out).
Attached Files
File Type: zip #188 - LOG75.zip (1.06 MB, 65 views)
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Old 01-16-2011, 12:19 AM   #2
Skookum
Registered Users
 
Posts: 850
 

Join Date: Jan 2008
Location: Vancouver, Canada
Default

I took a look at this log, and it seems like you were using a 6v BEC? There are lots of 0.3v drops, and one 0.5v drop. That might mean the BEC was browning out more for very short periods. The SK720 samples voltage at about 40Hz, so it might have missed shorter, deeper dropouts. I've used powerstor supercaps from digikey as a low-cost fix for this kind of thing.
Skookum is offline        Reply With Quote
Old 01-16-2011, 12:41 AM   #3
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

thank you for the very prompt response - most appreciated.

Firstly, what do you use to look at the underlying data - is this included in the SK-720 software?

Secondly, I am using a Western Robotics Hercules Super BEC (14S 10A/15A Peak) - I had assumed this would be quite good for regulating the voltage to 6V. Do you think this has problems?

More details on my setup here: http://www.helifreak.com/showthread.php?t=270678
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Old 01-16-2011, 12:44 AM   #4
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

as another thought, attached are the logs from the two "good" flights - do these have similar brownouts?

thanks!
Attached Files
File Type: zip LOG74.zip (1.61 MB, 40 views)
File Type: zip LOG73.zip (1.63 MB, 45 views)
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Old 01-16-2011, 01:04 AM   #5
Skookum
Registered Users
 
Posts: 850
 

Join Date: Jan 2008
Location: Vancouver, Canada
Default

I looked at the other two, they were a bit better than log75. If you have that BEC then I'm less sure of the problem, it should have plenty of current.

Still, the problem is most likely a connector or brownout. I would try wiggling things around, check for binding servos at extremes, and try binding the tail servo by hand and see if it resets with sharp stick motion. A bound tail servo is close to a dead short.

The plotting software is a future release, but it isn't ready yet.
Skookum is offline        Reply With Quote
Old 01-16-2011, 01:18 AM   #6
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

thanks, will look at all connections and the tail. I cannot seem to get the tail to not jitter, so maybe some issues as you say. I have also been taol to get rid of the Align DS620 as my tail servo so this may be a part of it.

odd that the Spektrum satellite receivers were both ok (ie: not flashing). Would then SK-720 be more sensitive to voltage fluctuations?
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B

Last edited by boltor; 01-16-2011 at 01:22 AM.. Reason: removed a question that was already answered! (about the software)
boltor is offline        Reply With Quote
Old 01-16-2011, 01:48 AM   #7
Skookum
Registered Users
 
Posts: 850
 

Join Date: Jan 2008
Location: Vancouver, Canada
Default

If I remember right, the SK resets at about 3.1 volts, and the spek sats a little below that. The SK's internal power supply also powers the sats. By the time BEC voltage gets below 3.5v though it usually keeps going down until the digital servos cut out, and they can take longer to reset than anything else. There's always a chance there is another cause, but 99% of the time it's power.
Skookum is offline        Reply With Quote
Old 01-16-2011, 03:11 AM   #8
alexf1852
Registered Users
 
Posts: 3,059
 
My HF Map location
Join Date: Dec 2009
Location: FL
Default

Quote:
Originally Posted by Skookum View Post
...
The plotting software is a future release, but it isn't ready yet.
Hi Art,

Was there any reason why you couldn't just export your log data in a format that would be compatible with this free data tool? http://www.logview.info/vBulletin/

It would save you a lot of time coding one up yourself.
__________________
MSH Protos * 2, SAB 500, 630
alexf1852 is online now        Reply With Quote
Old 01-16-2011, 07:25 PM   #9
logolew
Registered Users
 

Join Date: May 2009
Location: Canada
Default

Hello Boltor

I had the same problem with a Hercules Super BEC. I had a reset with a 401 gyro using 5.2v that I assumed was a problem with the 401. I then converted to flybarless with the SK720 and changed to 6v and had a reset. Some time had elapsed between these resets so I did not connect the two incidents. I assumed that the problem was the 720, and sent it in for replacement, Art took care of me with top notch service. With the new 720, while still carrying the helicopter out, the 720 reset. The problem was NOT the 720. I removed the Hercules, and installed and old 5A Ultimate BEC. I also installed a standard NIMH 4 cell battery, and ran that to the other side of the power bus through a switch. I also use the jumper between the 2 sides of the power bus, as everything is at the same voltage. This setup has worked perfect and is very cheap insurance. It gives me complete power redundancy, and allows me the power up the 720 without powering up the ESC/motor. The battery, once charged, is maintained by the BEC, and eliminates any voltage drops. In my pre flight, I plug in my main bat, ensure the 720 powers up, un plug it, then switch on the backup battery, ensure the 720 powers, then plug the main bat back in. This ensures that one or the other has not failed, and is being masked by the other.

Please do not do as I did and assume the Hercules is fine, send it in!!

Thanks, Jason
logolew is offline        Reply With Quote
Old 01-18-2011, 04:41 AM   #10
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

thanks Jason, appreciate the advice. will take a good look at everything including the WR (which until now I had never heard anything bad about)
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Old 01-18-2011, 04:47 AM   #11
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

@ Skookum - Art, attached is a new log - if you have time (and doesn't distract you from 2.03!!!), would you mind taking a look at letting me know what the voltage is doing? any big drops again?

btw, I have just discovered that one tooth in the main gear has completely sheared off!!!! I was unaware of this, but wonder if this is contributing to high vibration levels. any thoughts?
Attached Files
File Type: zip LOG86.zip (219.9 KB, 39 views)
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Old 01-20-2011, 04:37 AM   #12
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

Art - any chance you could take a look at the attached log. With your advice I have:
- reduced vibration - better mounting, reduced tension on cables
- checked all connections

Would appreciate if you could check whether there are still big voltage drops.

thanks!
Attached Files
File Type: zip LOG93.zip (1.65 MB, 38 views)
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Old 01-20-2011, 06:23 AM   #13
fusionsx00
Registered Users
 
Posts: 8,239
 

Join Date: Sep 2010
Location: usa
Default

Im glad I did not get that bec
wr
__________________
DX8
X2MKS95i
X3
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

X5Xera
fusionsx00 is online now        Reply With Quote
Old 01-20-2011, 07:11 AM   #14
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

I'm not certain yet that we have identified the BEC as the issue. have done some other changes and will see how they go...
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Old 10-09-2011, 06:42 PM   #15
phenault
Registered Users
 

Join Date: Jun 2011
Location: Rhode Island
Default

I have had the same auto reset issue using a scott grey reactor X. Not to revive an old thread. Also had a vibration index of 10
phenault is offline        Reply With Quote
Old 10-09-2011, 09:12 PM   #16
fusionsx00
Registered Users
 
Posts: 8,239
 

Join Date: Sep 2010
Location: usa
Default

Man I'm glad I went with direct 2s lipo for my power.

I know bec are pretty reliable, but there is cases like these.

Just one less problem I have to deal with.
__________________
DX8
X2MKS95i
X3
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

X5Xera
fusionsx00 is online now        Reply With Quote
Old 10-09-2011, 10:00 PM   #17
phenault
Registered Users
 

Join Date: Jun 2011
Location: Rhode Island
Default

funny thing is, im running a 2s 3600mah outrage...
phenault is offline        Reply With Quote
Old 10-10-2011, 12:15 AM   #18
fusionsx00
Registered Users
 
Posts: 8,239
 

Join Date: Sep 2010
Location: usa
Default

So what's the bec for
__________________
DX8
X2MKS95i
X3
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

X5Xera
fusionsx00 is online now        Reply With Quote
Old 10-10-2011, 12:45 AM   #19
boltor
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2007
Location: Australia
Default

wow, old thread. I have put this incident down to old batteries. 6HV / SK720 combo is going strongly now (just sorted out some tail vibes). very happy with the performance of the BEC. have also replaced my DX8 with Futaba 8FG / sbus - very pleased with this change.
__________________
Compass 6HV FBL | Stock Motor | CC 80HV Ice2 ESC, gov via SK720 | SK-720 FBL & PowerBus | R6203SB Rx, sbus
MSH Protos 500 | Scorpion 3026-880 | CC 75A Ice Lite ESC, gov via SK720 | SK-720
Other: Spektrum DX9 | iCharger 208B
boltor is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Skookum Robotics


Skookum Robotics Skookum Robotics SK-360 SK-540 & SK-720 Digital Flybar

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com