Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Hitec Radios > Hitec Gyro/Servos


Hitec Gyro/Servos Hitec Gyro and Servo Support


Reply
 
Thread Tools Display Modes
Old 09-05-2012, 02:07 PM   #1
turko
Registered Users
 

Join Date: Sep 2009
Location: new westminster,B.C. canada
Default hitec 5084

I purchased a hitec 5084 servo for my blade 450 and am running it with the stock gl 210 mems gyro. Is it ok to run servo in digital mode? I read that some people were burning out the servo while running it in digital mode.I tested the servo today and it was very jittery and not smooth at all. Possibly a bad servo?
__________________
Blade 300 CFX, nano cpx , mcpx bl, dx6i,blade 450 3d

Last edited by turko; 09-07-2012 at 08:49 AM..
turko is offline        Reply With Quote
Old 12-04-2012, 09:48 PM   #2
minititinflyer
Registered Users
 
Posts: 1,621
 

Join Date: Dec 2007
Location: hollywood fl
Default

it could be a a bad one i just found out what to do to run the servo with out makeing it burn up you need to run it on 1520qu 250hz not 333hz
__________________
blade msr!, blade mcpx! ,blade 130x!, trex 250!, ,mini titan e325 v2! ,gaui hurricane 425e! ,trex 600 esp!, trex 700e! ,Hitec Aurora 9!, spektrum dx6i!
ikon! quark! !AMA# 1021263!
minititinflyer is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Hitec Radios > Hitec Gyro/Servos


Hitec Gyro/Servos Hitec Gyro and Servo Support

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com