Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Thunder Tiger Electric Helis > Titan X50E


Titan X50E Thunder Tiger Titan X50E Helicopters


Reply
 
Thread Tools Display Modes
Old 11-19-2012, 11:21 PM   #1
superem
Registered Users
 

Join Date: Jun 2012
Location: New York
Default 6 degrees at mid stick

Brought an X50e. This will be my first fbl heli.

Graduated from a Blade 450 3d. With new technology and a heli this big, I want to make sure everything is correct.

Looking at the manual, it calls for -4 to +10 with 6 degree pitch at mid stick. Is this correct? I spun her up last night and she didnt want to lift up. As i put the throttle back to low position, it would get light and want to lift off. Everything is build as per the manual.

Please help. So far this heli is hasnt been friendly to me. Been about a month since I built it but no maiden yet.

BeastX
Savox Servos
DX6i
superem is offline        Reply With Quote
Old 11-20-2012, 06:52 AM   #2
bluepilot2003
Registered Users
 
My HF Map location
Join Date: Apr 2011
Location: Tucson, AZ
Default

The only thing that makes sense to me is the pitch is the wrong direction. I did that with this heli after i took apart the rotor head because of too much play in it. When I put it back together, I didn't check the direction of the pitch and tried to lift it off and it wouldn't go. I found out I put the head together backwards and the pitch was working the opposite direction it was supposed to be.

Hope this helps.
__________________
Goblin 500, Rave ENV electric, multiple planks
bluepilot2003 is offline        Reply With Quote
Old 11-21-2012, 09:36 AM   #3
ghenders
Registered Users
 
Posts: 208
 
My HF Map location
Join Date: Jun 2011
Location: Atlanta, GA
Default

Superem - Sounds like you have the pitch setting in your Tx moving in the wrong direction. Here is a test you can do - when you move the collective stick (left Tx stick) up, does the swash move up or down? If it moves down then you need to go into your swash settings on your Tx and go from (for example +60 to -60) to reverse the direction the swash moves when you give a postive collective pitch command on the Tx.
__________________
Thunder Tiger X50e FBL / Thunder Tiger Mini-Titan e325 FBL / Blade Mcpx
ghenders is offline        Reply With Quote
Old 11-24-2012, 04:02 AM   #4
spootman
Registered Users
 
Posts: 1,825
 
My HF Map location
Join Date: Nov 2008
Location: Worcester, MA
Default

Like the others pointed out, sounds like your pitch is reversed. If you set it up like your blade 450, it'll be wrong. The swash on the blade moves the opposite direction of most other helis. Good luck with the new bird.
spootman is offline        Reply With Quote
Old 11-26-2012, 10:51 PM   #5
superem
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2012
Location: New York
Default

If you guys are correct, then the manual is wrong.

superem is offline        Reply With Quote
Old 12-07-2012, 06:11 AM   #6
WessCo
Registered Users
 
Posts: 589
 
My HF Map location
Join Date: Dec 2007
Location: Summerville, GA
Default

Don't worry about the swash plate movement. Look at your blades. Does the leading edge go up when you move the stick up? If not, change it to where it does.
WessCo is offline        Reply With Quote
Old 12-09-2012, 10:45 PM   #7
superem
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2012
Location: New York
Default

Change the pitch direction and all is well.

Was finally able to maiden the heli for like 2 mins.

Im about 5 feet off the ground and the motor quits on me and she gently settles down.

The battery was fully charged.
superem is offline        Reply With Quote
Old 12-10-2012, 01:10 PM   #8
bluepilot2003
Registered Users
 
My HF Map location
Join Date: Apr 2011
Location: Tucson, AZ
Default

Sorry to hear that! What setup do you have for your heli?
__________________
Goblin 500, Rave ENV electric, multiple planks
bluepilot2003 is offline        Reply With Quote
Old 12-10-2012, 02:49 PM   #9
superem
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2012
Location: New York
Default

AR7200BX, Ice 100 ESC, Ace Rc BL Motor with Savox servos.

8S 4000 batteries with a 2200 3s for the BX and Servos.

When I got to the field, connected the batteries, and tried to spool up, no response from the motor. I changed to another battery pack and got no response. I powered her down and powered back up and was able to get the motor to spool.

I took her up, hovered and did some forward flight. Then the motor died. Everything was cool. No signs of overheating on the electronics.

I think the throttle calibration was off. Went home and calibrated it but have not been able to try it out with the crappy weather we've been having .
superem is offline        Reply With Quote
Old 12-10-2012, 08:36 PM   #10
bluepilot2003
Registered Users
 
My HF Map location
Join Date: Apr 2011
Location: Tucson, AZ
Default

CC Bec?
__________________
Goblin 500, Rave ENV electric, multiple planks
bluepilot2003 is offline        Reply With Quote
Old 12-11-2012, 04:41 AM   #11
superem
Registered Users
Thread Starter Thread Starter
 

Join Date: Jun 2012
Location: New York
Default

Yes for the BEC

For the 2 mins that it was up in the air, it was very stable and responsive.

Hope to get a full flight in soon.
superem is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Thunder Tiger Electric Helis > Titan X50E


Titan X50E Thunder Tiger Titan X50E Helicopters

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com