Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Flight Stabilization


Flight Stabilization Flight Stabilization


Reply
 
Thread Tools Display Modes
Old 11-26-2012, 12:37 PM   #1
mmarmouz
Registered Users
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default Horrible crash APS today/Testing for first time

Hi Everybody,

I have setup and recheck everything 10 times ! Seen videos from Align, have checked this forum ! Everything was ok.

Well it happened, i was about 50-80 feets, then switched to APS Mode, it happened so fast, Helicopter went down like a bullet to hit the ground, it went down really straight !

It's a 500 DFC PRO, i had and i was lucky around 240$ of repair to do on it !

So what happend, i am trying to understand.

Did resetup the 3GX when i had added my APS, maked sure i go Right on the AIL travel in the 3gx setup.

All my pitch curves are Strait line, -100/0/100 (Normal and Idleup), throttle Normal is 0-50-100 and IdleUp 85 all the way.

I am just thinking that when Align say straight line 0/50/100, they really mean on my futaba 8fg, -100/0/-100 ? witch is -11 degres too + 11 degres ?? or they mean 0/50/100 really from 0 degres to +11 degres. (MAYBE THIS IS MY PROBLEM)

Gyro working fine, able to switch ok from 3GX/APS/GPS when it's in the ground !

Was able to pass the vibration test in normal more, hoovering for 30 sec and then landed.

So anyone have any idea of what happened ? like i said, it went down very leveled from 70 feets like a bullet to crash on the landing skids.

Thanks
mmarmouz is offline        Reply With Quote
Old 11-26-2012, 03:30 PM   #2
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

I did read the manual again and it should be at -100/0/100 pitch curves for normal and idle up ! so middle stick is 0 pitch. All ok.

Throttle is 0/50/100 normal and 85-85-85-85-85 for idle up.

I did check that channel 3 is throttle and 6 is pitch. i am using the 8fg.

So i don't see any probleme here.

I did pass accross a thread here regarding the APS Gyro Gain need to be lowered from 50% to 30% on all 3 dials. Does this can be my problem ? and why the heli just wend down very leveled to the ground like a bullet ? i was in idle UP 1, mean 85% throttle.

thanks
mmarmouz is offline        Reply With Quote
Old 11-26-2012, 03:39 PM   #3
HedgeHeli
Registered Users
 

Join Date: Mar 2010
Location: UK
Default

Sorry to hear this, Sounds to me like the stability is working but the pitch is wrong. What is your blade pitch at mid stick in DIR setup mode?
HedgeHeli is offline        Reply With Quote
Old 11-26-2012, 03:55 PM   #4
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

0 degres in middle stick in DIR MODE.

Question : Do i need to disconnect the APS while doing the 3GX settings ? That is what i did. I think i saw on the manual that you need to disconnect the APS before doing the 3GX setup. (Please confirm)

-11/0/+11

So lower stick is -10.9 and max stick is +11

DIR first elevator moved to the front, then ail moved to the right.

Middle stick elevator and middle stick ail in DIR, 0 degres everywhere.

Fly well in 3GX mode.

thanks
mmarmouz is offline        Reply With Quote
Old 11-26-2012, 04:05 PM   #5
HedgeHeli
Registered Users
 

Join Date: Mar 2010
Location: UK
Default

Quote:
Originally Posted by mmarmouz View Post
Do i need to disconnect the APS while doing the 3GX settings ? That is what i did. I think i saw on the manual that you need to disconnect the APS before doing the 3GX setup. (Please confirm)
I don't do this and have been using APS since its release.

This is quite strange as you say the heli was level on the way down indicating that the APS was controlling attitude. Did you have throttle / pitch at or above mid stick?

You also have this other thread about the failsafe. I use Futaba as well but mine is an 8J. I have the exact settings as shown in the manual which is 0 for APS 30 for GPS and -100 for failsafe. When on the bench and you flick from 3GX to APS to GPS do the lights on both the 3GX unit and the APS unit match what is shown in the manual?
HedgeHeli is offline        Reply With Quote
Old 11-26-2012, 08:05 PM   #6
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Quote:
Originally Posted by HedgeHeli View Post
I don't do this and have been using APS since its release.

This is quite strange as you say the heli was level on the way down indicating that the APS was controlling attitude. Did you have throttle / pitch at or above mid stick?

You also have this other thread about the failsafe. I use Futaba as well but mine is an 8J. I have the exact settings as shown in the manual which is 0 for APS 30 for GPS and -100 for failsafe. When on the bench and you flick from 3GX to APS to GPS do the lights on both the 3GX unit and the APS unit match what is shown in the manual?

Hi DedgeHeli,

Thanks for the reply, well let me give you the more information can,

My normal pitch is -100/-50/0/50/100, and throttle for normal is 0/25/50/75/100

so i don't use it only for take off, i do take off ok, then switch to IDLE UP

My idleup pitch is -100/-50/0/50/100 and Throttle is 85/85/85/85/85

I hoovered for about 20/30 seconds, then switched to APS. Then it went down leveled and hit the ground, reallly faaaast !

Now my heli is on my desk and i will give you all the pictch information, throttle no need, my engine is disconnect with the half of my heli on my desk

WITH 3GX

LEFT STICK LOWER POSITION : -12 PITCH
LEFT STICK CENTERED : 0 PITCH
LEFT STICK HIGHER POSITION : 12 PITCH

Same for NORMAL AND IDLE UP

Now my left stick is centered with the heli on my desk leveled, PITCH IS at 0 degres

I now switch from 3gx to APS, and this is what happened

It stay around 0.2-0.5 for 2 3 seconds, then go to +12.2 pitch
This is with the APS Position set to Type GY AVCS Rate 0%

Now i have noticed it act different when is at Type GY NORM Rate 0%
It slowly go to -0.2 -0.5 Then after 10 sec it's at -6 Pitch and around 30 seconds it's at -8 pitch and some time after it go to -9.2 Pitch.

PItch Horn is high, Ail Horn is low and Elevator Horn is low.

So i don't get it, should it be to GY NORM or GY AVCS Rate 0% for APS Mode ?

On the video/manual, they say to put that at 0% only, they don't tell if NORM or ACVS ? and if GYRO Type at GY or NORMAL (Confusing) specially i see it act differently when it is set to NORM or ACVS

now to answer to your question, if light when switching from 3gx to aps to gps is as the manual

Yes it it as the MANUAL, No MODE LED at 3GX, constant LIGHT APS, flashing at GPS, 3gx led also on the right color, Flash green on 3gx, flash orange on APS and flash red on GPS.

This is the case with GY at NORMAL 0% or ACVS 0% !

But manual say to put 0% and not to choose any or normal or ACVS !

And for the failsafe, well i am unable to put -100% and they say when you turn off the transmitter, all lights flash on the APS, on my case Mode light flash, as it go to GPS mode. On the video demo, all lights flash in failsafe ! so i don't get it.

Thanks
mmarmouz is offline        Reply With Quote
Old 11-26-2012, 09:53 PM   #7
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

I did some more testing on my desk

With the default attitude/Level/Vertical gain at 12, when i switch from 3gx to aps mode with the heli on a desk, the swashplate move quickly and do not stay at the same position. To make it smoother and see that the swash plate hold position and there is no dramatic changes is to put all theses 3 gain at 8 AM position. witch is almost lower position i think. i know people say 30% so that should be like 9AM position ?
mmarmouz is offline        Reply With Quote
Old 11-27-2012, 01:25 AM   #8
HedgeHeli
Registered Users
 

Join Date: Mar 2010
Location: UK
Default

Hey,

This is 100% TX set up my reply is long but hopefully worth reading.

Not sure how long you've been flying so sorry if this is all old news. If you set up your swash to be 0 degrees at mid stick, when you spool up you will not take off until the left stick (mode 2) is about three quarters of the way above mid stick, for most helis this equates to about 5 degrees of positive pitch. The way APS works is that when you flick into APS mode the swash immediately jumps to about 5 degrees. Furthermore APS then limits you - the pilot - to about 1.5-2 degrees of pitch control in each direction so your max pitch control is roughly from 3-7 degrees allowing you to move the heli up and down while in APS mode, but when at mid stick, the heli just hovers (5 degrees of pitch). Flick out of APS into 3GX at mid stick and your heli will fall - descend because you've just gone from 5 degrees pitch to 0 degrees pitch.

I think you have 2 things going on.

1) Your not seeing the full travel limit of the channel controlling APS. This is showing up in 2 ways, first you cannot set -100 and second you seem to get two modes at 0, AVCS and Normal. AVCS mode more commonly called Heading Hold and Normal mode or Rate mode control how a gyro behaves. With a Futaba system 0 is neither one or the other, it is the cross over point between the two -1 your in Rate/normal +1 your in AVCS/Heading Hold - for Spectrum this cross over point is 50, 51 HH - 49 Rate.

Now 0 for Futaba is only mid way if the Travel on that channel is equal I.e. 20-20 50-50 or 100-100. As an example if the travel is set to 10-6 then the mid point would be 2.

I think that something is wrong with your travel and once you fix it, not only will you see the full -100 so you can set the failsafe ( and yes all four lights should flash when you turn the TX off) but you will also see 0 as 0 not 0 AVCS or 0 NOR - at least that's what I see on my Futaba 8J.

You must fix this first as this may well lead you to other TX issues. Once fixed do a full DIR set up

2) The reason why you dropped out the sky while under full attitude control is confusing. I've seen another post with this issue but I did not see the answer. However if you read my explanation of how APS works then we can look to test your set up. On the bench, with the left stick at mid stick when you flick into APS does the swash jump up?

Let me know and we can work out what's wrong.

Paul
HedgeHeli is offline        Reply With Quote
Old 11-27-2012, 03:57 AM   #9
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Quote:
Originally Posted by HedgeHeli View Post
Hey,

This is 100% TX set up my reply is long but hopefully worth reading.

Not sure how long you've been flying so sorry if this is all old news. If you set up your swash to be 0 degrees at mid stick, when you spool up you will not take off until the left stick (mode 2) is about three quarters of the way above mid stick, for most helis this equates to about 5 degrees of positive pitch. The way APS works is that when you flick into APS mode the swash immediately jumps to about 5 degrees. Furthermore APS then limits you - the pilot - to about 1.5-2 degrees of pitch control in each direction so your max pitch control is roughly from 3-7 degrees allowing you to move the heli up and down while in APS mode, but when at mid stick, the heli just hovers (5 degrees of pitch). Flick out of APS into 3GX at mid stick and your heli will fall - descend because you've just gone from 5 degrees pitch to 0 degrees pitch.

I think you have 2 things going on.

1) Your not seeing the full travel limit of the channel controlling APS. This is showing up in 2 ways, first you cannot set -100 and second you seem to get two modes at 0, AVCS and Normal. AVCS mode more commonly called Heading Hold and Normal mode or Rate mode control how a gyro behaves. With a Futaba system 0 is neither one or the other, it is the cross over point between the two -1 your in Rate/normal +1 your in AVCS/Heading Hold - for Spectrum this cross over point is 50, 51 HH - 49 Rate.

Now 0 for Futaba is only mid way if the Travel on that channel is equal I.e. 20-20 50-50 or 100-100. As an example if the travel is set to 10-6 then the mid point would be 2.

I think that something is wrong with your travel and once you fix it, not only will you see the full -100 so you can set the failsafe ( and yes all four lights should flash when you turn the TX off) but you will also see 0 as 0 not 0 AVCS or 0 NOR - at least that's what I see on my Futaba 8J.

You must fix this first as this may well lead you to other TX issues. Once fixed do a full DIR set up

2) The reason why you dropped out the sky while under full attitude control is confusing. I've seen another post with this issue but I did not see the answer. However if you read my explanation of how APS works then we can look to test your set up. On the bench, with the left stick at mid stick when you flick into APS does the swash jump up?

Let me know and we can work out what's wrong.

Paul
Paul,

Thank you for the answer ! Well when that happend, i was already in IdleUp and hoovering at around 3/4 left stick, when i flicked to APS it just went down. as for the pitch curve in normal and idle up, align say to put it from -100/0/+100, you even see it on the video with a futaba t8j i think. so yes i know that at around 3/4 stick is +5, and the point where i should hoover. But why it went from +5 to 0 when switched to APS ? it supposed to stay at +5 degrees no ?

As for the Gyro Travel, i don't have any idea if it's limited. But i can choose from 0 to 100 in ACVS, from 0 to 100 in normal witch is supposed to be 0 to -100 i think. but it's really confusing. i understand the 0% is not ACVS or NORMAL, it's the middle point, but on a futaba 8fg, you have to choose from NORMAL or ACVS under GY gyro. maybe the t8j work in a different way. but the travel you are talking about is the endpoint ?? All my endpoint is default, did not play with them, it's at 135 100 100 135

I will go over all my options on my futaba, and see the travel limits for the GYRO.

I was able to set the -100 in Normal mode by setting my GPS position at NORMAL 100% unstead of 30%, have put the GPS position switch, went to failsafe, and press set, it reat -100%, went back again to GYRO setting, 3rd position and set it back to 30%, so now when i switch to GPS, it work, and when i turn off the transmitter, all led flashs ! so the -30% i was getting at failsafe before, is because my gps switch was set to that ! -30%, and before i have set the failsafe on the gyro, i switched the 3 position switch to the lower (GPS), and then i have putted my throttle left stick in the middle and pressed set on the throttle failsafe, it rear 70%

thanks paul, hope i will get it by the time i get my repair parts in 2 days, now my heli is all tear down.

thanks.
mmarmouz is offline        Reply With Quote
Old 11-27-2012, 08:28 AM   #10
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Quote:
Originally Posted by HedgeHeli View Post
Hey,

This is 100% TX set up my reply is long but hopefully worth reading.

Not sure how long you've been flying so sorry if this is all old news. If you set up your swash to be 0 degrees at mid stick, when you spool up you will not take off until the left stick (mode 2) is about three quarters of the way above mid stick, for most helis this equates to about 5 degrees of positive pitch. The way APS works is that when you flick into APS mode the swash immediately jumps to about 5 degrees. Furthermore APS then limits you - the pilot - to about 1.5-2 degrees of pitch control in each direction so your max pitch control is roughly from 3-7 degrees allowing you to move the heli up and down while in APS mode, but when at mid stick, the heli just hovers (5 degrees of pitch). Flick out of APS into 3GX at mid stick and your heli will fall - descend because you've just gone from 5 degrees pitch to 0 degrees pitch.

I think you have 2 things going on.

1) Your not seeing the full travel limit of the channel controlling APS. This is showing up in 2 ways, first you cannot set -100 and second you seem to get two modes at 0, AVCS and Normal. AVCS mode more commonly called Heading Hold and Normal mode or Rate mode control how a gyro behaves. With a Futaba system 0 is neither one or the other, it is the cross over point between the two -1 your in Rate/normal +1 your in AVCS/Heading Hold - for Spectrum this cross over point is 50, 51 HH - 49 Rate.

Now 0 for Futaba is only mid way if the Travel on that channel is equal I.e. 20-20 50-50 or 100-100. As an example if the travel is set to 10-6 then the mid point would be 2.

I think that something is wrong with your travel and once you fix it, not only will you see the full -100 so you can set the failsafe ( and yes all four lights should flash when you turn the TX off) but you will also see 0 as 0 not 0 AVCS or 0 NOR - at least that's what I see on my Futaba 8J.

You must fix this first as this may well lead you to other TX issues. Once fixed do a full DIR set up

2) The reason why you dropped out the sky while under full attitude control is confusing. I've seen another post with this issue but I did not see the answer. However if you read my explanation of how APS works then we can look to test your set up. On the bench, with the left stick at mid stick when you flick into APS does the swash jump up?

Let me know and we can work out what's wrong.

Paul
Paul,

At what value you have your 3 dials on the APS Module ?

Thanks
mmarmouz is offline        Reply With Quote
Old 11-27-2012, 10:25 AM   #11
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

I was reading about the pitch curve of -100/0/+100 and some people put the pitch curve like align said, but the ajust the rods to have -2 at lowest position + 5 for center and +12 for highest.

what do you think about that ?

Like i said, putting all my APS Gain at around 20%, swash plate is stable when i switch from 3GX to APS, with the heli on my desk.

thanks
mmarmouz is offline        Reply With Quote
Old 11-27-2012, 12:15 PM   #12
HedgeHeli
Registered Users
 

Join Date: Mar 2010
Location: UK
Default

I would stick with the manual for now just have +-12 and 0 degrees at mid stick. Regarding the pots it can't do any harm lowering them but they are to adjust flight characteristics rather than stop the heli flying out the sky. People on v1 APS with smaller lighter helis found it works better with the pots at about 30% or pointing towards 10:30/11:00. Personally I adjust them according to conditions, anywhere from 30% in light winds to 75% in high winds (20mph or more)

If I where you, once i had the heli back together I would re-do DIR then on the bench switch from 3GX to APS and see if the swash rises or falls. If it rises then that's good if it falls that's your issue.

If it rises and all other pre-flights check out ok - especially the ones checking for auto correction then the next step is to get back out and fly. This time get as much height as you can comfortably fly then switch to APS if it acts wired just switch it back to 3GX and you will be back in control.

Good luck and let me know how that swash behaves.
HedgeHeli is offline        Reply With Quote
Old 11-27-2012, 01:40 PM   #13
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Quote:
Originally Posted by HedgeHeli View Post
I would stick with the manual for now just have +-12 and 0 degrees at mid stick. Regarding the pots it can't do any harm lowering them but they are to adjust flight characteristics rather than stop the heli flying out the sky. People on v1 APS with smaller lighter helis found it works better with the pots at about 30% or pointing towards 10:30/11:00. Personally I adjust them according to conditions, anywhere from 30% in light winds to 75% in high winds (20mph or more)

If I where you, once i had the heli back together I would re-do DIR then on the bench switch from 3GX to APS and see if the swash rises or falls. If it rises then that's good if it falls that's your issue.

If it rises and all other pre-flights check out ok - especially the ones checking for auto correction then the next step is to get back out and fly. This time get as much height as you can comfortably fly then switch to APS if it acts wired just switch it back to 3GX and you will be back in control.

Good luck and let me know how that swash behaves.
Hi Thanks for the reply,

When you say :

If I where you, once i had the heli back together I would re-do DIR then on the bench switch from 3GX to APS and see if the swash rises or falls. If it rises then that's good if it falls that's your issue.

My problem now, is that when i rise the heli, i feel the swash goind down, and when i put the heli down, i feel it going up, but very small amount, i can't only feel it by my fingers.

My issue, is when i switsh to APS, the swash plate go a little up, but it does not stay level, that why the pitch is negative or too much positive.

When you say to switch from 3GX to APS on my desk, and see if the swash plate go up, it is supposed to go up and stay LEVEL ???? like all the 3 links will stay level ?

because that's not what it is happening now, when i switch to APS, the LEVEL go down, AIL go down and PITCH go up (Example) each time is different, sometime i get positive pitch +9 sometime negative pitch -9.

When i lowered the gain to 20-25%, when i switch to APS, it stay lever and pitch go from 0 to +5, it stay level for like 10-15 seconds, and then begin to be negative or postive pitch, but all 3 channels are unbalanced ! level go down, pitch go up, ail go down (Example)

As for the failsafe, i think t8fg must be different from yours, i can go set -100 by putting GY NORMAL 100% set failsafe then switch back to GY NORMAL 30% witch is GPS Mode, now i have all 3 position switch correct 3GX/APS/GPS, and my failsafe is -100% (All led flashs) so i think i will not touch this anymore for now.

Thank you

thanks
mmarmouz is offline        Reply With Quote
Old 11-27-2012, 02:51 PM   #14
HedgeHeli
Registered Users
 

Join Date: Mar 2010
Location: UK
Default

Quote:
Originally Posted by mmarmouz View Post
My problem now, is that when i rise the heli, i feel the swash goind down, and when i put the heli down, i feel it going up, but very small amount, i can't only feel it by touch
This is normal so that's good.

I've done a quick vid to show you my swash as I switch from 3GX to APS

YouTube
"> YouTube
" type="application/x-shockwave-flash" width="425" height="350">


HTH
HedgeHeli is offline        Reply With Quote
Old 11-27-2012, 03:53 PM   #15
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Quote:
Originally Posted by HedgeHeli View Post
This is normal so that's good.

I've done a quick vid to show you my swash as I switch from 3GX to APS

http://www.youtube.com/watch?v=L53GnsQJI6w&sns=em">http://www.youtube.com/watch?v=L53GnsQJI6w&sns=em" type="application/x-shockwave-flash" width="425" height="350">


HTH
Thank you very much for the Videos ! Really appreciated.

Ok i got, so it should go a little UP and stay level.

Mine was not doing that at all, the swash plate just goes on one side ! it does not stay leveled !

What Gain do you have ? 10h30 AM ? like you said before ? i will pay attention next time i build, should be in 2 days. I will make a video and post it here just to show you what i have, and i will set the swashplate with a leveler and reset the 3gx again.

Thanks ! Your's look like it go up and stay really leveled ! so that it what i will try to reach before i can try it next time in the air

Thanks !!

Can you please confirm what do you have as PITCH in Lower/Mid/Higher.

thanks
mmarmouz is offline        Reply With Quote
Old 11-27-2012, 04:01 PM   #16
HedgeHeli
Registered Users
 

Join Date: Mar 2010
Location: UK
Default

My pleasure hope it helps. My pitch is +-10 degrees.
HedgeHeli is offline        Reply With Quote
Old 11-27-2012, 06:50 PM   #17
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Thanks again ! I will let you know the swash react to the 3gx to aps switch!

Have a good night !
mmarmouz is offline        Reply With Quote
Old 12-01-2012, 12:13 AM   #18
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Hi,

I am rebuilding my 500 dfc, i did a video of my 500 reacting to the aps activation, difference story from yours Paul ! Check it out, i can t figure out what is the issue! Is it possible the aps gyro is defective ??, well below is the video


Thanks

Last edited by mmarmouz; 12-01-2012 at 11:33 AM..
mmarmouz is offline        Reply With Quote
Old 12-01-2012, 11:30 PM   #19
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Anyone can confirm is my aps is reacting as it is supposed to with the heli on the ground ?

Compensation of the swashplate is correct in both 3gx and aps mode

Thanks
mmarmouz is offline        Reply With Quote
Old 12-02-2012, 10:40 AM   #20
mmarmouz
Registered Users
Thread Starter Thread Starter
 

Join Date: Oct 2012
Location: Laval, Quebec, Canada
Default

Hi,

Did some more testing of the APS on the ground. I noticed one thing.

With No gps signal or GSP disconnected. When i switch to APS, it go to ~5 ~6 degres (hoovering) and stay level around that pitch !!!

With GPS Signal, swash plate act weird, it can go up to ~9 ~11 pitch !! or lower than 5 pitch ..

Anyone have an idea ? can it be the GPS module the issue ? or defective ?
mmarmouz is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Flight Stabilization


Flight Stabilization Flight Stabilization

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com