Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Thunder Tiger GT5 FBL System


Thunder Tiger GT5 FBL System Thunder Tiger GT5 Flybarless Electronics


Reply
 
Thread Tools Display Modes
Old 11-30-2012, 10:14 PM   #1
Bladecpnitro
Registered Users
 
Posts: 3,105
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default EXI 450 HK FBL Head GT-5

I've had a GT-5 since the 19th of November which was Monday. I installed an HK 450 FBL head on my EXI 450 last night. All I need now is to grab up 3 good servos. I've been running Align DS 415 MG's and Henge 933's. Henge 933 cases are brittle and break mounting tabs even in normal flipping and rolling and the Align DS 415 Mg's have soft metal gears that bend teeth in a crash and I just opened up a dud Align DS 415 MG brand new in the package the other day and it wouldn't budge or buzz, it was DOA , so I think I'm gonna switch servos, I just haven't figured out which ones yet.

One thing cool about the GT-5 is it will work with analog servos too. Since this is my first FBL controller I don't know what others may handle analog servos. Digital is the way to go though as it makes its full holding power even at minimal movement while an analog makes full holding power only at full throw. I read elsewhere that the Gt-5 does not work well with Align and Hitec servos and JR, Futaba, or MKS would be better choices.

I've done all the stuff in my radio and gyro that I can do without flying it and testing it, killed all the expo in the gyro, set p and I gains in swash and tail for a starting point. That'll save me some time when I get the servos. I still have to mount the Gt-5.

While I've been waiting on my FBL head all I've had to do was fly sim and read Gary Writes GT-5 fine tuning pdf. and the manual a half a dozen times. I think I'm going to like the GT-5 and haven't even flown it yet.

I find I'm having to double tap the GT-5 too many times to exit some programs. Long as it eventually works its still nice to have a screen with numbers to look at. All though it would be a nice feature to have PC access, its really not needed. I imagine once its set well, it won't have to be fooled with much.


I already have my tail mechanically trimmed in rate mode with the Futaba GY 520 which is about 7 degrees of mechanical right rudder with servo arm at 90 degree's center, so that should be setup perfect for the GT-5 as well. I don't know why they don't suggest 7 or 8 degrees of right mechanical rudder in the manual as a starting point. Instead the manual says to hover the heli and let someone observe if the rudder servo arm is at 90 degrees. If the arm is forward you have to shorten the rod until the rudder servo arm is at 90 degrees in a hover.

Since the GT-5 doesn't have a rate mode, I suppose one could plug the rudder servo up to an RX long enough to set the tail at 7 or 8 degrees of right rudder mechanically with rudder servo arm at 90 as a starting point.

I'm excited to try it.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!

Last edited by Bladecpnitro; 12-12-2012 at 05:10 AM..
Bladecpnitro is online now        Reply With Quote
Old 12-09-2012, 10:06 AM   #2
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default

I have this thing installed and closer to getting setup. I'm using the HK 450 head same as RJX with the stock 450 FB main shaft. Right now I'm using almost 75% collective to get the blades at zero pitch and I can't extend my servo to swash arms much farther to raise the swash at center stick. Do I need to purchase a different set of swash to servo links or shorter main shaft?


Also when checking gyro direction for swash I'm not getting any elevator movement at all. Everything is moving and functioning in proper direction I even checked servo by servo individually. I mounted my gyro backwards so the wires would come off the left side and I could dbl tap on the right side of the helicopter. That shouldn't be an issue should it?

Thanks
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!
Bladecpnitro is online now        Reply With Quote
Old 12-09-2012, 10:27 PM   #3
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default Small Update:

I mistakenly messed up the xyz axis calibration in the tool menu on my GT-5 and had to go through that whole PITA tonight of recalibrating the axis and it did not help the problem I was having with swash correction.

Do yourselves a favor and jot those values down that are in xy and z axis menu's inside the tool menu. It they get screwed up it'll save you a lot of time.
I think I messed mine up the first day i got it and powered it up and scrolled through all its menu's

It turns out that the GT-5 has to be mounted with the screen sideways to the helicopter. I had conveniently placed mine where the wires would come off the left side down to my RX and the touch pad was on the right because everything was useable there.

Now so I can still operate the touch pad and not lenthen some wires I'll have to have the wires all jammed into the anti-rotation platform and the touch pad facing the back of the heli. Turning the gyro a 1/4 turn made the difference in the swash correction, that reversing and normal switching a few items, install position, elevator and aileron correction directions.

When I rolled the heli right and left the gyro saw elevator movement with the gyro mounted like I had it. Which was gyro over the boom, screen readable from nose of the heli looking towards the boom. Worked great there except I couldn't remap x and z axis.

The only thing the manual says concerning mounting is that it must be mounted perpendicular to the helicopter. I sorta figured that just meant square. I should have known without a way to remap the X and Z axis it wouldn't work rotated a 1/4 turn I guess. The manual could have mentioned that there was no way to remap them.


Its finally ready to fly. I hate I wasted that brand new Gyro tape, man that stuff had a grip. I didn't fly sim or my 250 all weekend fooling with this thing. I hope it'll be worth it. I've never flown FBL.

Its right now though now finally. I have worried with that swash not correcting all day no matter what setting I put in there. It didn't do right until I figured out it was a 1/4 turn out.

I just almost feel like I could give it an Alan Szabo full collective punch out right off the matt with some forward flips in there 1st time out without even testing it.

I better at least test the gains though for some wag and wobble.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!
Bladecpnitro is online now        Reply With Quote
Old 12-10-2012, 12:28 PM   #4
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default OMG!

I love it. I snuck one pack in this morning, resulting in my first FBL flight.

For some reason I had to rebind after plugging my motor in to get the gyro to boot. I tried lifting off at 60 % gain first, got light on the skids and the disk just felt too wobbly. I let off the throttle and switched to 100% gain and eased it into a hover. It just barely had a tiny tail wag so I flipped into idle up and blasted around a little, did a few pitch pumps to make sure I had working negative pitch and then. I did a backwards flip and it flipped so fast it went about a 1/4 turn past dead level nose in inverted. Im like WOAH! this things flips crasy fast.

I ended up sticking with the Align DS 415 MG's, I do have one Henge 933 on left aileron while the other DS 415 Mg is being shipped. I initially used 20 + expo on elevator and aileron on my DX7 and may change it later. I can tell already Im going to love the GT-5. This is the original, not the 5.1, I'm running it with an AR6100e RX so I have a failsafe. I've noticed if I unplug anything while power is on, the GT-5 boots next time with an error message and it takes several reboots to get past it.

Surprisingly it feels like a FB heli but flips much quicker and flies more precise.
I love it, wouldn't you know its pouring the rain this evening. Maybe it'll break before dark.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!

Last edited by Bladecpnitro; 12-12-2012 at 05:19 AM..
Bladecpnitro is online now        Reply With Quote
Old 12-10-2012, 03:21 PM   #5
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default

Thought I'd add a pic of my bird. Its nothing special but has been a blast and fairly cheap to operate. I had the GT-5 mounted with the wires coming strait off the left side but the gyro won't correct swash in that position, it thinks roll movement is elevator movement.

My Setup:

Fail Safe - is working well with esc plugged into the throttle channel of my AR6100e RX. I tested this with a servo plugged into the RX throttle channel with the system booted and killed the radio duplicating a radio brown out and the servo goes to 0 like it should. The Castle Creations 10 amp BEC is plugged strait to the throttle port on the GT-5


Tarot Anti-rotation bracket
- These are cheap, shiny aluminium and much longer than the stock gyro mount. Works great for FBL gyro's.

Servo Arms - Balls are set 12.5 mm's out on Align DS 415 MG's, one hole in from the end. This is perfect for doing zero adjustment in the GT-5 swash menu, all set to 100. All cyclic servo endpoints are left at the stock 250 as well in the GT-5

Transmitter
is set to 1 servo in swash setup for the GT-5 to do all swash mixing. Swash is set to 120 in the GT-5 Swash menu.

Ailerons and elevator have been set to 8 degrees of pitch with aileron and elevator endpoints in the radio.

Check elevator pitch with blades 90 degrees off the side of the heli at center stick with a pitch gauge, GT-5 in programming mode moving the elevator stick full forward and aft.

Check ailerons with a blade strait off the nose of the heli at center stick GT-5 in programming mode, moving stick full right and left.

30+ expo on elevator, ailerons and rudder.

Gyro gain is set to 100 and 60 for the low. For some reason I had to set my radio gyro gain to zero to get like 97 gain to show up in the GT-5 white numbers against black background and couldn't get that any higher.


Swash Setup On Heli
Cyclic servos arms at 90 degrees, center stick with a little help from the GT-5 servo-sub trim function in the servo menu.
Swash is set 12 mm's above the frame at center stick, adjust swash links accordingly. My swash links are 35mm center to center.
links to HK FBL head are 43 mms to get zero pitch on blades at center stick on collective. These measurements may vary. Long as you get zero pitch at center stick.
Larger balls come with the HK FBL head for the washout arms to attach to the swash, I used standard Align links on the lower end of the long grip arms and didn't change the balls. The HK balls take 2mm shorter screws than what is standard and to be honest I wrapped 2mm's of thread and glue around 2 screws near the head to shorten them up for those HK balls. The counter sink is very deep in these balls.

GT-5 Settings
Gyro mounted with wires facing forwards or backwards in the direction of the boom, crossways wont' work.
Swash Menu-
elevator- 100
aileron -100
pitch -100 to get 11 degrees +/- pitch on the blades at full collective and low. Check that in setup mode with a pitch gauge. This number will vary from user to user. Longer servo arms and that pitch number would be lower.
type- set to electric All these numbers will vary from user to user this is working for me.

Servo Menu
set all swash servo speed to 3/4 of their actual speed ( example- servo speed - .1 seconds set servo speed to .075
Set tail servo speed same way .My Futaba S9257's speed is .08 divided by 4 x 3 = .06
Set servo frequency as well for tail and swash
Also set sub trim on servos at center stick here keeping it minimal as possible or .

PI menu - these are my tested working settings. The heli is flying very good now but still tweaking.

Swash:

P- 120 I had it all the way up to 125 but noticed a little blade bounce back on piro flips.
I- 110
I-D -100
D-Sense - 25
Feed Forward-85 If you blades are too aggressive on rolls lowering this will soften aggressiveness.
I-Lim 18 - makes the bird track strait in fast forward flight.
Hovering - 4 lowering this supposedly makes the bird more snappy and responsive.


Tail:
tail P- 94
tail I - 84 - affects piro consistency in forward flight. Working great!
D-Sense - 5 increases tail stopping if I go anymore than 5 here I get a gentle tail wag in f&b flips
Dynamic- 50
DMA Cyclic 0 - affects tail if it kicks one way doing tic-tocs
DMA Pitch 0
Stop 0 - For more gear stripping tail stopping action.


The bird is flying very good with these settings, far far better than it ever did as a FB heli with these settings. I'm gonna keep editing my GT-5 settings as I finish tweaking it. I had a hard time finding any info on setting up the HK FBL head with link and swash measurements by searching the web. A few fellow helifreaker's helped me considerably in PM to get those setup.

Swash measurement at center stick from bottom of swash to top of frame is a real time saver. You just hold the swash at 12mms above the frame, servos at center stick and measure the balls to see how long the links need to be and its easy to remember.

Maybe this will help someone out there who just got a GT-5 and HK or RJX FBL head for their 450. Ive tagged it too so the search engines can pic up on it easier.

Oh I almost for the pics of the bird.



__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!

Last edited by Bladecpnitro; 12-19-2012 at 05:59 PM..
Bladecpnitro is online now        Reply With Quote
Old 12-12-2012, 11:39 AM   #6
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default

I flew 2 packs yesterday evening. On 1st spool up the gyro wasn't correcting the tail and the heli spun around on the mat.
I rebooted TX and the GT-5 several times but the slider wouldn't move when I moved the tail by hand. I finally got that holding, not sure how exactly. It seems like if I land and adjust anything in the PI menu, I have to reboot everything to get the tail gyro holding again.

I flew it, did a couple flips and nose down funnels so far the only thing I'm seeing that makes it less than awesome is some tail wag in forward and backwards flips. My flip rate is a little slower since I set Aileron and Elevator pitch to 7 degrees with TX Endpoints instead of the GT-5 servo endpoints.

Rudder ATV's needed bumping up a little to speed the tail up a little. In fact I bumped Rudder ATV's up to 125 for the 2nd pack and it still wasn't quite as fast as I like it, also caused a little tail wag so had to land and back the P value off some on the tail. I may bump those ATV's on up to 150.

I'm worried about the tail gyro not holding sometimes at boot up. I flew 1 pack this morning with no problems. I wondered if it might be because I took it out of a warm house out into 45 degree temp?
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!

Last edited by Bladecpnitro; 12-13-2012 at 06:19 PM..
Bladecpnitro is online now        Reply With Quote
Old 12-13-2012, 06:55 PM   #7
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default I like the GT-5 well enough to buy a new one if this one proves to have a problem

Well I took it out at lunch to get a quick flight in and no tail gyro again. I now know that it is in the gyro because of the handy indicator on the GT-5 that shows the helicopter movement. When it malfunctions the counter numbers aren't moving in the Tools - Y Axis menu either.

Twice I took it out this evening and booted it 10 times or so and the tail gyro was dead each time. The tail moves with the TX but the gyro doesn't correct the tail at all. I took it back inside both times and it was back on first boot up. WTF?

I finally got it to boot up with the tail working 2 or 3 times in a row and took it back outside and ran 3 packs. The only thing I did different was change D Sense from 0 to 5 and its booted with the tail gyro working every time since. I hope that might have been the problem. It did it yesterday with a setting of 23 so I doubt I could be that lucky.

I turned the D- Sense off because I read someone did that to stop tail wag during flips. I never did get to fly it with a setting of 0 on the Tail D Sense but a setting of 5 seems to have eradicated the tail wagging during flips.

Its really flying good, I'm amazed at how well it flies. Im gonna go ahead and max out the rudder ATV's to make the tail quicker and I need to speed the flip rate up a bit more, its actually flipping slower than the FB version now with 7 degrees of cyclic pitch in the TX ATV's. I originally had that set up in the GT-5 servo end points and it flipped ridiculously quick the first time I flew it.

The P gains seem pretty good right now. Hopefully Saturday if it don't rain I'll get a chance to fine tune the P and I parameters as well as the D Sence. The manual says the Tail D- Sense shouldn't have to be altered. I bought this gyro used and have no idea what the default settings are.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!

Last edited by Bladecpnitro; 12-13-2012 at 09:09 PM..
Bladecpnitro is online now        Reply With Quote
Old 12-14-2012, 05:42 PM   #8
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default

After flying 3 packs tonight, that makes a total of 14 flights I have under my belt now and I truly am more impressed with the GT-5 every day.

I came home from work, bumped up the Swash P gain to 80, I to 70 and maxed out the rudder ATV's for faster piro rate. Also bumped up my elevator and aileron ATV's 3 points for faster flip rate. This birds head speed is 2821. That's at the low end for 3D flying and may be why my bird doesn't quite flip fast enough with 7 degrees of cyclic.

Anyhow it flew the best its flown yet tonight.



I'm getting it better dialed in each time I fly it. I've found that if I set the Tail D- Sense any higher than 5 for the tail I'm getting a gentle tail wag only during flips. Set to 7 just barely wags a little on flips so that is set to 5 now.

Tomorrow I plan to get the P gains up as high as I can get them without wag or wobble and get the I and D-Senses fine tuned. I believe that's already done in the tail.


Also last night I tested my fail safe in the RX 6100e with a servo plugged into the throttle channel instead of the ESC. Fail safe lowers the servo as I cut the radio off. That's good to know that's working and honestly the 1st time I've ever tested it and know that its working. I always bind my TX with T hold on but never tested it.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!
Bladecpnitro is online now        Reply With Quote
Old 12-15-2012, 05:00 PM   #9
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default

I went ahead and got my first FBL crash out of the way today 17 flights into FBL. I had to do emergency surgery on it and got it revived just in time to get 3 packs in before dark.


1 Blade, feathering shaft, main shaft, skids, canopy and I straitened the boom. While I was at it I installed my Align 415 MG in place of the left aileron Henge 933 and set the gear lash a little better it was a little tight.

I was gonna spend the day getting my gains as high as possible without wag or wobble and anyhow had just raised the gains on the swash a little before I shutdown on my second pack, put a new pack in and flew around a minute no wobble or wag so I flipped about 8 feet off the ground in Normal mode. I flipped it back over before it hit the ground and might have completely saved it but instinct hit Throttle Hold.

Oh well not how I planned on spending the after noon but its all part of it I guess.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!
Bladecpnitro is online now        Reply With Quote
Old 12-19-2012, 06:14 PM   #10
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default

All right! I've really been enjoying the heli with this gyro. Im pretty sure my gains are where they are gonna stay a while. I gains are working fine 10 increments below P gains and I really can't see changing them any right now.

I nailed my 1st continuous slow double piro flips today with a bright yellow canopy almost at dark and a very exciting moment it was. I almost didn't fly and I thought about rain coming tomorrow so I got my tired carcass out there and accomplished something new.


I was having trouble booting the heli with the tail gyro not functioning. I talked to TT about it and they said to make sure the heli is absolutely still when its booting up and if it fails to boot with a working tail gyro wait 10 seconds before rebooting. That has helped a lot, since that conversation in email I have had only 1 occurrence where it booted without a working tail gyro. The trick is to plug it up fast and hold it from rocking.


There is another instance where it boots to an err_R 135 and stops. I nudged the right aileron arm a little, rebooted and got it past that fine.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!
Bladecpnitro is online now        Reply With Quote
Old 12-25-2012, 07:42 PM   #11
kahn6976
Registered Users
 

Join Date: Jan 2012
Location: Taiwan
Default

For reference.

Is my E325V2 FL parameter.

*PI manual

Swash

P
95

I
70

I D-stick
80

D-Sense
35

Feed forward
85

I-lim
18

Hoover
4

Exit


Tail


P
70

I
70

D-Sense
22

Heck-D-DB
5

Heck-Asym
3

Stick-dyn
40

DMA-cyclic
0

DMA-pitch
0

Smooth Stop
0

Exit


*Swash manual



type
electro


Pitch
95


Aileron
85


Elevator
85


Exit



*Servo manual



Tail Typ
1500
Tail-delay
0.045
Tail Freq
333
Swash Typ
120
Delay
0.075
SW Freq
75
kahn6976 is offline        Reply With Quote
Old 01-13-2013, 07:58 PM   #12
Bladecpnitro
Registered Users
 
Posts: 3,105
Thread Starter Thread Starter
 

Join Date: Mar 2011
Location: Griffin Ga, United States
Default

Well I had my 2nd crash since I've installed the Gt-5. The 1st time I flipped in normal mode shortly after making some adjustments in the GT-5 and today an elevator servo died on me while practicing traveling half piro flips. I guess I was over working it I don't know. I'm gonna need some better servos that's the 3rd Align servo Ive lost since like august.

Whats so crasy about it is it was making my Gt-5 reboot over and over and over until I finally found the bad locked up elevator servo and unplugged it. Also my RX was losing power long enough to start blinking.


I didn't solve the rebooting GT-5 and RX light blinking until I unplugged the locked up elevator servo. I had to test my servos with my RX. I guess I could have taken them all out of the GT-5 and plugged them up one by one until I found the bad one. It showed up quickly plugged into the RX though. The GT-5 simply would not function at all with a locked up servo in the mix. I guess there goes trying to save it if I had the skills to get it down with 2 working servos.



I've learned that a Y harness to feed power to the GT-5 and the RX will not work. It causes my RX to go into bind mode for some reason. Power has to run to the throttle channel on the GT-5 and the throttle of my ESC runs to the throttle channel in my RX which gets its power through the elevator on GT-5 to elevator on RX ports.

Still loving the GT-5 and will use one on a larger bird when I get one.
__________________
DX 7, Trex 550E-MicroBeast-BLS251. 450 Pro, FBL, Belt, GT-5.1 KST 115, Futaba 9257, Scorpion 10 on 4S (!)
If its fixed don't break it!

Last edited by Bladecpnitro; 01-16-2013 at 04:45 AM..
Bladecpnitro is online now        Reply With Quote
Old 01-14-2013, 02:59 PM   #13
Grimracer
Registered Users
 
Posts: 91
 

Join Date: Jan 2010
Location: Urbana IL
Default

Good reading. Thanks!

Grimracer
__________________
Michael "Grimracer" Zaborowski

Highspeed Dirt!
Grimracer is offline        Reply With Quote
Reply

Tags
450 fbl conversion, exi 450 hk fbl head gt-5




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Thunder Tiger GT5 FBL System


Thunder Tiger GT5 FBL System Thunder Tiger GT5 Flybarless Electronics

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com