Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 700 Class Electric Helicopters


700 Class Electric Helicopters 700 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
Thread Tools Display Modes
Old 12-03-2012, 07:09 PM   #1
Sladex
Registered Users
 
Posts: 316
 

Join Date: Jul 2012
Location: Japan
Default Beastx Throttle Problem.

The throttle doesnt work. Ive been looking around and i says that the esc has to beep. It only beeps when i put the 12s in. I am using a cc bec pro and the cc hv120
Sladex is offline        Reply With Quote
Old 12-03-2012, 07:18 PM   #2
K2Freak
Registered Users
 
Posts: 3,750
 
My HF Map location
Join Date: Mar 2009
Location: Samish Island, WA
Default

Are you sure that you calibrated the esc correctly? If not, go to the documents section of castle creations site and read about fep and gov setup. It must be done right...
__________________
700E CHP DL 780mm / VBar Silverline / HK-4525 / YGE 160HV / MKS DS660A+ / MKS DS760 / Gryphon Quasar / Scorpion BUG / KDE / Futaba T12Z

Citizen 97
K2Freak is offline        Reply With Quote
Old 12-03-2012, 07:27 PM   #3
GT86
Registered Users
 
Posts: 989
 

Join Date: Mar 2010
Location: Phoenix, AZ USA
Default

Yep, that's probably the problem. You have to teach the esc what your throttle low and high points are.

http://www.castlecreations.com/support/documents.html and toward the bottom you'll see a how to on setting up fixed endpoints. You have to do this first even if you plan on using the governor.

Also, it won't arm unless it sees a zero throttle signal, so check and see that your throttle hold is set to zero.

Sent from my Galaxy Nexus using Tapatalk 2
GT86 is offline        Reply With Quote
Old 12-03-2012, 07:47 PM   #4
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Quote:
Originally Posted by GT86 View Post
Yep, that's probably the problem. You have to teach the esc what your throttle low and high points are.

http://www.castlecreations.com/support/documents.html and toward the bottom you'll see a how to on setting up fixed endpoints. You have to do this first even if you plan on using the governor.

Also, it won't arm unless it sees a zero throttle signal, so check and see that your throttle hold is set to zero.

Sent from my Galaxy Nexus using Tapatalk 2
I dont have the kit to plug it into my computer?
Sladex is offline        Reply With Quote
Old 12-03-2012, 08:02 PM   #5
K2Freak
Registered Users
 
Posts: 3,750
 
My HF Map location
Join Date: Mar 2009
Location: Samish Island, WA
Default

They gave you a gift cert for one in the package. Or if not then buy one. You need it to use the cc controller on a heli. Period. That should never have been optional.

You calibrate the endpoints without the castlelink, but probably a bad choice to try to fly - Too many settings not exposed via stick programming. You don't teach cc, you find the points with tx atv. Its not like hw, scorp.

And your throttle hold will not be zero. You will "find" that too.

Read those docs until you understand what you are doing. They are good.
__________________
700E CHP DL 780mm / VBar Silverline / HK-4525 / YGE 160HV / MKS DS660A+ / MKS DS760 / Gryphon Quasar / Scorpion BUG / KDE / Futaba T12Z

Citizen 97
K2Freak is offline        Reply With Quote
Old 12-03-2012, 08:12 PM   #6
ddj74
Registered Users
 
Posts: 2,400
 

Join Date: Dec 2011
Location: Winter Haven, Florida 33880
Default

make sure your throttle curve is 0, 25, 50 , 75, 100
__________________
AMA #1039539
ddj74 is offline        Reply With Quote
Old 12-03-2012, 11:34 PM   #7
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

It still doesnt work. ive got it to spin 3 times so far. But it the esc keeps blinking. I think that means it is in programming mode. My ATV Is L = 52% And H=102%. Something is wrong.
Sladex is offline        Reply With Quote
Old 12-04-2012, 12:03 AM   #8
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Bump
Sladex is offline        Reply With Quote
Old 12-04-2012, 12:21 AM   #9
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Come on guys i need this in the next few minutes
Sladex is offline        Reply With Quote
Old 12-04-2012, 12:23 AM   #10
ShaneJourdan
 
Posts: 3,418
 

Join Date: Oct 2010
Location: Sandy, Oregon
Default

Is your throttle curve set linear. 0 25 50 75 100



Sent from my iPad using Tapatalk HD
__________________
Goblin 700 - XF495 KDE - HC3SX - CC160
Trex 700 - 700 MX - HC3SX - CC120
Blade 450X - Scorpion 2221-6 - BD3sx -CC 50
Gaui X2 - BD3sx - Talon 25 - DS95i
ShaneJourdan is offline        Reply With Quote
Old 12-04-2012, 12:26 AM   #11
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Quote:
Originally Posted by DoctorJ View Post
Is your throttle curve set linear. 0 25 50 75 100



Sent from my iPad using Tapatalk HD
Yep
Sladex is offline        Reply With Quote
Old 12-04-2012, 12:33 AM   #12
K2Freak
Registered Users
 
Posts: 3,750
 
My HF Map location
Join Date: Mar 2009
Location: Samish Island, WA
Default

Castles have a light? I don't remember that.

Slow down and figure this out. You need the castlelink before you are going anywhere anyway.
__________________
700E CHP DL 780mm / VBar Silverline / HK-4525 / YGE 160HV / MKS DS660A+ / MKS DS760 / Gryphon Quasar / Scorpion BUG / KDE / Futaba T12Z

Citizen 97
K2Freak is offline        Reply With Quote
Old 12-04-2012, 12:37 AM   #13
ShaneJourdan
 
Posts: 3,418
 

Join Date: Oct 2010
Location: Sandy, Oregon
Default

Opp's didn't see that was posted already.

When setting end points you set both to around 50%, then went high and it alerted at 102, sounds ok. Then you went low and it alerted at 52?? What?

You should be going down not up. But what ever this can't be right.



Sent from my iPad using Tapatalk HD
__________________
Goblin 700 - XF495 KDE - HC3SX - CC160
Trex 700 - 700 MX - HC3SX - CC120
Blade 450X - Scorpion 2221-6 - BD3sx -CC 50
Gaui X2 - BD3sx - Talon 25 - DS95i
ShaneJourdan is offline        Reply With Quote
Old 12-04-2012, 12:38 AM   #14
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Quote:
Originally Posted by K2Freak View Post
Castles have a light? I don't remember that.

Slow down and figure this out. You need the castlelink before you are going anywhere anyway.
I am gonna have to wait days for it to come. Isn't there a way to do it without it . The hv escs have a light on the side. It will basically ask you the questions through the light.
Sladex is offline        Reply With Quote
Old 12-04-2012, 12:40 AM   #15
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Quote:
Originally Posted by DoctorJ View Post
Opp's didn't see that was posted already.

When setting end points you set both to around 50%, then went high and it alerted at 102, sounds ok. Then you went low and it alerted at 52?? What?

You should be going down not up. But what ever this can't be right.



Sent from my iPad using Tapatalk HD
Yeh. It alerted fine at 102 then I went beep beep beep really fast and then when I switched to low it did the same and beeped on 52. I think I know the culprit, the ar7200bx fail safe thingy
Sladex is offline        Reply With Quote
Old 12-04-2012, 12:41 AM   #16
ShaneJourdan
 
Posts: 3,418
 

Join Date: Oct 2010
Location: Sandy, Oregon
Default

Quote:
Originally Posted by Sladex View Post
I am gonna have to wait days for it to come. Isn't there a way to do it without it . The hv escs have a light on the side. It will basically ask you the questions through the light.
Good luck with that, you really need the cc link. Your in airplane mode.


Sent from my iPad using Tapatalk HD
__________________
Goblin 700 - XF495 KDE - HC3SX - CC160
Trex 700 - 700 MX - HC3SX - CC120
Blade 450X - Scorpion 2221-6 - BD3sx -CC 50
Gaui X2 - BD3sx - Talon 25 - DS95i
ShaneJourdan is offline        Reply With Quote
Old 12-04-2012, 12:44 AM   #17
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Quote:
Originally Posted by DoctorJ View Post
Good luck with that, you really need the cc link. Your in airplane mode.


Sent from my iPad using Tapatalk HD
Oh **** off course. Ty
Sladex is offline        Reply With Quote
Old 12-04-2012, 12:44 AM   #18
ddj74
Registered Users
 
Posts: 2,400
 

Join Date: Dec 2011
Location: Winter Haven, Florida 33880
Default

Quote:
Originally Posted by Sladex View Post
Yeh. It alerted fine at 102 then I went beep beep beep really fast and then when I switched to low it did the same and beeped on 52. I think I know the culprit, the ar7200bx fail safe thingy
Re-bind the controller but make sure you are at low stick and switches are at default settings such as throttle hold on or whatever. If a switch isn't in a certain position other then what it was when you bound the controller it will not initialize.
__________________
AMA #1039539
ddj74 is offline        Reply With Quote
Old 12-04-2012, 08:47 AM   #19
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

Any other suggestion guys
Sladex is offline        Reply With Quote
Old 12-04-2012, 08:59 AM   #20
Sladex
Registered Users
 
Posts: 316
Thread Starter Thread Starter
 

Join Date: Jul 2012
Location: Japan
Default

I need as many suggestions as possible
Sladex is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 700 Class Electric Helicopters


700 Class Electric Helicopters 700 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com