Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Mikado Logo Helicopters > Mikado Logo 700 Xxtreme


Mikado Logo 700 Xxtreme Mikado Logo 700 Xxtreme Helicopters Discussion


Reply
 
Thread Tools Display Modes
Old 12-04-2012, 03:00 PM   #1
OICU812
Registered Users
 
Posts: 9,793
 
My HF Map location
Join Date: Oct 2005
Location: Edson, Alberta, Canada
Default Logo 700 revised manual available on Mikado site

As title states new revised manual is available on Mikados website for viewing and download. As new manuals hit their press in future will also reflect small changes. Nothing major really just some clarifications for folks to make the manual bit more accurate.
__________________
...Once upon a time there were Nitros, flybars & frequency pins...Shawn
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


OICU812 is offline        Reply With Quote
Old 12-04-2012, 07:22 PM   #2
Ace Dude
Registered Users
 

Join Date: Sep 2004
Location: USA
Default

Here's the direct link to the manual. They sure did an amazing job on the manual.

LOGO 700 XXtreme Manual
Ace Dude is online now        Reply With Quote
Old 12-05-2012, 12:15 AM   #3
zguy
Registered Users
 
Posts: 748
 

Join Date: May 2006
Location: SoCal
Default

Spacer location on the rear tail supports fixed.
Gear ratio is still wrong and for the 800.
What else?
zguy is offline        Reply With Quote
Old 12-05-2012, 08:08 AM   #4
sgrim80
Registered Users
 
My HF Map location
Join Date: Nov 2006
Location: Lehigh Valley, PA
Default

Quote:
Originally Posted by zguy View Post
Spacer location on the rear tail supports fixed.
Gear ratio is still wrong and for the 800.
What else?
Hmmm I still see the spacer in the same location it was in my manual which is wrong I believe. It still shows the spacer and the boom support going between the two aluminum halves. I assembled mine with the spacer and support UNDER the bottom metal support.
__________________
Team Mikado USA!!!
Team Scorpion!
Logo 600SX - Scorpion 4035-560, 10s 4400 packs
Logo 690SX - Stock Scorpion motor, 12s 4500 packs
sgrim80 is offline        Reply With Quote
Old 12-05-2012, 08:15 AM   #5
zguy
Registered Users
 
Posts: 748
 

Join Date: May 2006
Location: SoCal
Default

Quote:
Originally Posted by sgrim80 View Post
Hmmm I still see the spacer in the same location it was in my manual which is wrong I believe. It still shows the spacer and the boom support going between the two aluminum halves. I assembled mine with the spacer and support UNDER the bottom metal support.
You're right, I looked too quick.
So what changed?
zguy is offline        Reply With Quote
Old 12-05-2012, 08:49 AM   #6
sgrim80
Registered Users
 
My HF Map location
Join Date: Nov 2006
Location: Lehigh Valley, PA
Default

From what I can tell none of the pictures changed but alot of the descriptions are better. I think it is a nice improvement but they missed that error in the parts explosion for the tail assembly. Maybe there will be another revision coming as well
__________________
Team Mikado USA!!!
Team Scorpion!
Logo 600SX - Scorpion 4035-560, 10s 4400 packs
Logo 690SX - Stock Scorpion motor, 12s 4500 packs
sgrim80 is offline        Reply With Quote
Old 12-05-2012, 11:24 AM   #7
OICU812
Registered Users
 
Posts: 9,793
Thread Starter Thread Starter
 
My HF Map location
Join Date: Oct 2005
Location: Edson, Alberta, Canada
Default

You guys are ahead of me, I only got word & made the post, I have not reviewed it to the fine stuff honestly just haven't had time to sit at home in front of PC long enough. I'll need to look into this and let Ralph know.
__________________
...Once upon a time there were Nitros, flybars & frequency pins...Shawn
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


OICU812 is offline        Reply With Quote
Old 12-05-2012, 12:17 PM   #8
HeliKhanh
Registered Users
 

Join Date: Sep 2010
Location: Norway, Lørenskog
Default

It's not possible to mount the boom support between the two aluminum halves, so I put mine under the bottom as well. I think it should be that way.
HeliKhanh is offline        Reply With Quote
Old 12-09-2012, 10:31 PM   #9
kevinbj
Registered Users
 

Join Date: Feb 2010
Location: baltimore
Default

Do you guys have any advise on the tail rotor? Mine is not right once I put everything together I can still pull both blade grips apart a few mm.. It's lik part# 4571 is to long..
kevinbj is offline        Reply With Quote
Old 12-09-2012, 11:40 PM   #10
dahld
Registered Users
 

Join Date: Aug 2007
Location: Bakersfield, California, USA
Default

Without looking-up the part number, I'll assume you're referring to the t/r spindle. I measured one on two different calipers, and it should be 50.7mm long. And I checked three XXtreme tail assemblies I could find in the garage, and none have any end play between the blade grip and the hub. So, something's up

Do you have the spacers installed that go between the o-rings and the inside blade grip radial bearing? Since the tail hub has dampeners, this spacer is not present on other designs, and thus I've seen it get left out.

(-: Dave
dahld is offline        Reply With Quote
Old 12-10-2012, 12:40 AM   #11
kevinbj
Registered Users
 

Join Date: Feb 2010
Location: baltimore
Default

Quote:
Originally Posted by dahld View Post
Without looking-up the part number, I'll assume you're referring to the t/r spindle. I measured one on two different calipers, and it should be 50.7mm long. And I checked three XXtreme tail assemblies I could find in the garage, and none have any end play between the blade grip and the hub. So, something's up

Do you have the spacers installed that go between the o-rings and the inside blade grip radial bearing? Since the tail hub has dampeners, this spacer is not present on other designs, and thus I've seen it get left out.

(-: Dave
Dave thank for taking time to help.. I have the brass spacer with shoulder part facing bearing .. So 3 dampers,brass spacer, bearing, inside bearing, shim, thrust bearing then screw /w small shim.. If I pull inside bearing lifts out creating space... May have to see if screw is going all the way down .. Any suggestions or I'm I missing a step?
kevinbj is offline        Reply With Quote
Old 12-10-2012, 09:45 AM   #12
dahld
Registered Users
 

Join Date: Aug 2007
Location: Bakersfield, California, USA
Default

It sounds like you have all the parts installed. If I was dealing with this, I'd at this point take the shaft out, measure it to make sure it was the right length, and then screw both the retaining bolts into the ends of the shaft, and confirm the bolts go all the way in, and their washers bottom-out on the shaft.

(-: Dave
dahld is offline        Reply With Quote
Old 12-10-2012, 11:44 AM   #13
kevinbj
Registered Users
 

Join Date: Feb 2010
Location: baltimore
Default

Quote:
Originally Posted by dahld View Post
It sounds like you have all the parts installed. If I was dealing with this, I'd at this point take the shaft out, measure it to make sure it was the right length, and then screw both the retaining bolts into the ends of the shaft, and confirm the bolts go all the way in, and their washers bottom-out on the shaft.

(-: Dave
Ok thanks will do
kevinbj is offline        Reply With Quote
Old 12-10-2012, 05:42 PM   #14
kevinbj
Registered Users
 

Join Date: Feb 2010
Location: baltimore
Default

Quote:
Originally Posted by dahld View Post
It sounds like you have all the parts installed. If I was dealing with this, I'd at this point take the shaft out, measure it to make sure it was the right length, and then screw both the retaining bolts into the ends of the shaft, and confirm the bolts go all the way in, and their washers bottom-out on the shaft.

(-: Dave
Thanks figured it out screw wasn't flush on both sides.. Now had to take 2.5 Allen key on both ends @ same time @ first I was jus turning one end @ a time.. Now it's a Beast..
kevinbj is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > Mikado Logo Helicopters > Mikado Logo 700 Xxtreme


Mikado Logo 700 Xxtreme Mikado Logo 700 Xxtreme Helicopters Discussion

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com