Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Electronics Support > Flight Stabilization


Flight Stabilization Flight Stabilization


Reply
 
Thread Tools Display Modes
Old 12-15-2012, 01:23 PM   #21
nightflyr
Registered Users
 
Posts: 14,479
 
My HF Map location
Join Date: Jan 2009
Location: Long Island, NY
Default

Wesley,
Just a question for you or anyone else..
I noticed in your video when you switch from manual mode to atti mode your swash deflect to the right and back to level when switched back to manual mode.

How is this deflection affecting your flight stability?
Does it cause a drift to the right? if so how are you correcting for it?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

nightflyr is online now        Reply With Quote
Old 12-15-2012, 01:31 PM   #22
Wesley888
Registered Users
 
Posts: 519
 
My HF Map location
Join Date: Feb 2012
Location: Long Island, NY
Default

It only does that while it is sitting on the bench not moving. While in the air, it doesn't move at all when I flip the switch from manual to Alt Hold.
__________________
Align 450, NAZA-H, Align 700e, Skookum SK 720, SK-GPS, DX8. ArduPilot. Talon 625 with brushless gimbal, Tarot T810 with Tarot 3-axis gimbal.
Wesley888 is offline        Reply With Quote
Old 12-15-2012, 01:35 PM   #23
nightflyr
Registered Users
 
Posts: 14,479
 
My HF Map location
Join Date: Jan 2009
Location: Long Island, NY
Default

Thank you
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

nightflyr is online now        Reply With Quote
Old 12-15-2012, 02:48 PM   #24
FPVflyer
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2012
Location: Central Europe
Default

Ok people, now I really want to put all in the trash.

I repeat completely the setup, so create a NEW model on the radio, with zero curves and zero trims, and I followed all the step in the order from the software. Before this, I updated the firmware.
All the steps have gone PERFECTLY! Exactly like the assistant software tell, but the problem remain: Manual mode, swashplate set in wrong position.

I've done another small video of all the servo monitoring from the Assistant software, where you can see that all is moving properly, swashplate and tail are perfect, except for swashplate in manual mode neutral position.

Here the new vid (sorry for poor quality, ever iphone ):

https://vimeo.com/55686133
Pass: freak

Please people, I'
FPVflyer is offline        Reply With Quote
Old 12-15-2012, 06:32 PM   #25
NexxuSix
Registered Users
 

Join Date: Feb 2011
Location: USA, IL, Northern
Default

Quote:
Originally Posted by FPVflyer View Post
Ok people, now I really want to put all in the trash.

I repeat completely the setup, so create a NEW model on the radio, with zero curves and zero trims, and I followed all the step in the order from the software. Before this, I updated the firmware.
All the steps have gone PERFECTLY! Exactly like the assistant software tell, but the problem remain: Manual mode, swashplate set in wrong position.

I've done another small video of all the servo monitoring from the Assistant software, where you can see that all is moving properly, swashplate and tail are perfect, except for swashplate in manual mode neutral position.

Here the new vid (sorry for poor quality, ever iphone ):

https://vimeo.com/55686133
Pass: freak

Please people, I'
Had a look at your video. I know this is a bit OT, but when I set up my Tarot Gyro on my Trex-500e I had the same problems. There are at least two screens associated with overall direction. One is for the servos, the other is for overall operation. The same appears with the Naza-H software. There is a screen for servo direction, and one for swashplate mix. Yes, it can be very confusing to get these two screen correct for the heli. For the Tarot gyro, it nearly took me an hour! But, now that I understand how a 3 axis gyro works, setting up the Naza-H was a lot easier. To me it looks like you might have either one servo reversed, or a setting in the swashplate mix not set correctly. Also, make sure you check your radio for servo direction as well. That can add to the confusion as well. For my DX8 all servos are set to Normal, except for Pitch, which is set to Reverse.

I hope this gives you some guidance... Good luck with your setup
NexxuSix is offline        Reply With Quote
Old 12-15-2012, 06:43 PM   #26
Wesley888
Registered Users
 
Posts: 519
 
My HF Map location
Join Date: Feb 2012
Location: Long Island, NY
Default

FPVflyer, could you go into the Setup tab to check a few things...

1) go to "Mode" and see if your mode switch really going to the "GPS", "A", and "M"

2) Swash. Make sure you have the correct Swash Type

3) Trim. Make sure you get 90 degree at all of your Servo trim.

4) And after that, double check again on the "Mix" screen and make sure the Cyclic Mix are following the direction on what the Setup screen shows.

For the Mix screen and the Feedback, watch the Wizard carefully FIRST. Then look at your heli afterward on the second cycle. Your heli needs to follow what the Wizard shows you. I think you got one of these 2 screens wrong. Even I missed one of the four tests in the Feedback screen.
__________________
Align 450, NAZA-H, Align 700e, Skookum SK 720, SK-GPS, DX8. ArduPilot. Talon 625 with brushless gimbal, Tarot T810 with Tarot 3-axis gimbal.
Wesley888 is offline        Reply With Quote
Old 12-15-2012, 07:00 PM   #27
Tahoe Ed
Registered Users
 
Posts: 1,193
 
My HF Map location
Join Date: Nov 2009
Location: Lake Tahoe/Las Vegas
Default

From here: http://helifreak.com/showthread.php?t=479611

The next section is the Feedback settings. I was lost with the pictures, but now I have it. In picture 1, pitch of your blades should go positive, negtive,center.
P2,Swashplate should tilt forward, backward, center
P3,Swashplate roll to left, right, center,
P4, Heading should pan to left, right, center by judging tail blades movement.
__________________
AMA #844172 DJI F550 A2 Lightbridge H3-2D DJI F450 Naza + GPS H3-2D 5.8gHz vTx DJI Phantom 2 Vision, DJI Phantom 2 GoPro3 with H3-3D and Data Link, DJI F330 with Naza + GPS
Trex 550 with WKH, Trex 500 with Naza H
Tahoe Ed is offline        Reply With Quote
Old 12-15-2012, 07:46 PM   #28
R_Lefebvre
Registered Users
 

Join Date: Nov 2010
Location: Canada
Default

Quote:
Originally Posted by Wesley888 View Post
Thanks Wesley, very good.

So what I can see from that is that they are using a lot of I-term on the rate. That is why it keeps moving after you hit the end of the stick, until the swash hits the end.

However, it does appear to have some amount of direct proportional as well, because the swash moves quite fast at the beginning of the stick movement.

It also seems like when you return the stick to center, it built-up I-term unwinds quite quickly, which is interesting. I wonder if they've done something there. I should compare that to where I'm at now. Just nice to have a benchmark.

Edit: ah very cool, it's very similar to mine. The only difference is it takes my I-term a bit longer to unwind when returning to center.
__________________
-Rob

Ardupilot/Arducopter Developer
R_Lefebvre is offline        Reply With Quote
Old 12-16-2012, 03:16 AM   #29
FPVflyer
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2012
Location: Central Europe
Default

Ok peoples, now I completely don't understand. On the time I write last post, and then I tried one more time, I simply turned on the copter and also manual mode is working perfectly! Don't know why, but better so. Tomorrow will maiden :-)

Thanks a lot for the help, the problem has been solved himselves, but all this thread help me a lot to better understand how the NAZA work!

Cheers

'flyer
FPVflyer is offline        Reply With Quote
Old 12-16-2012, 05:57 AM   #30
R_Lefebvre
Registered Users
 

Join Date: Nov 2010
Location: Canada
Default

I would check that a few times with a few reboots, make sure whatever happened "sticks".
__________________
-Rob

Ardupilot/Arducopter Developer
R_Lefebvre is offline        Reply With Quote
Old 12-16-2012, 06:05 AM   #31
FPVflyer
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2012
Location: Central Europe
Default

Already reboot the system a lot of times, everytime was working right!
FPVflyer is offline        Reply With Quote
Old 12-16-2012, 04:52 PM   #32
Wesley888
Registered Users
 
Posts: 519
 
My HF Map location
Join Date: Feb 2012
Location: Long Island, NY
Default

That's odd. Hope it maidens ok. Good luck.
__________________
Align 450, NAZA-H, Align 700e, Skookum SK 720, SK-GPS, DX8. ArduPilot. Talon 625 with brushless gimbal, Tarot T810 with Tarot 3-axis gimbal.
Wesley888 is offline        Reply With Quote
Old 12-19-2012, 03:49 AM   #33
FPVflyer
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2012
Location: Central Europe
Default

Maiden flight 100% success!
https://vimeo.com/55854611
pass: fpvlab

Thanks a lot for all the help guys!
FPVflyer is offline        Reply With Quote
Old 12-19-2012, 03:58 AM   #34
Wesley888
Registered Users
 
Posts: 519
 
My HF Map location
Join Date: Feb 2012
Location: Long Island, NY
Default

Congrats! It looks great!
__________________
Align 450, NAZA-H, Align 700e, Skookum SK 720, SK-GPS, DX8. ArduPilot. Talon 625 with brushless gimbal, Tarot T810 with Tarot 3-axis gimbal.
Wesley888 is offline        Reply With Quote
Old 12-19-2012, 08:05 AM   #35
zeeflyboy
Registered Users
 

Join Date: Oct 2009
Location: UK/Switzerland
Default

It's the best I've seen so far actually - none of the tail bobbing and slight wobbling that I've seen on a few other videos.

Think that's about as good an example of perfect auto hover as you could hope to get!
__________________
Blade mCP X - Brushless, XP-7A, HP05S
Gaui X2, BeastX/Scorpion 3400kv/YGE-30A/GS-093/DS95i
Align AH-1 Cobra (T-Rex 500)
Align T-Rex 600 EFL Pro, SK720/600MX/YGE-90HV/BL9180/BL9188
zeeflyboy is offline        Reply With Quote
Old 12-19-2012, 09:06 AM   #36
R_Lefebvre
Registered Users
 

Join Date: Nov 2010
Location: Canada
Default

That looks great! That's my benchmark.
__________________
-Rob

Ardupilot/Arducopter Developer
R_Lefebvre is offline        Reply With Quote
Old 12-19-2012, 07:54 PM   #37
Tahoe Ed
Registered Users
 
Posts: 1,193
 
My HF Map location
Join Date: Nov 2009
Location: Lake Tahoe/Las Vegas
Default

Quote:
Originally Posted by FPVflyer View Post
Maiden flight 100% success!
https://vimeo.com/55854611
pass: fpvlab

Thanks a lot for all the help guys!
That is a great result!!! Will you please share your settings and if this is a stock 600? Thanks.
__________________
AMA #844172 DJI F550 A2 Lightbridge H3-2D DJI F450 Naza + GPS H3-2D 5.8gHz vTx DJI Phantom 2 Vision, DJI Phantom 2 GoPro3 with H3-3D and Data Link, DJI F330 with Naza + GPS
Trex 550 with WKH, Trex 500 with Naza H
Tahoe Ed is offline        Reply With Quote
Old 12-20-2012, 02:32 AM   #38
zeeflyboy
Registered Users
 

Join Date: Oct 2009
Location: UK/Switzerland
Default

Definitely not a stock 600 Pro

Power train wise it's running a Scorpion HKIII 330kv, YGE90HV, 13T pinion straight cut pinion and 115T KDE main, Spin semi symmetrical blades on the head and tail, with a head speed around 1700rpm in that video.

Would be nice to know the sort of gains it's running though - so smooth....

Hopefully FPVflyer will post his settings!
__________________
Blade mCP X - Brushless, XP-7A, HP05S
Gaui X2, BeastX/Scorpion 3400kv/YGE-30A/GS-093/DS95i
Align AH-1 Cobra (T-Rex 500)
Align T-Rex 600 EFL Pro, SK720/600MX/YGE-90HV/BL9180/BL9188
zeeflyboy is offline        Reply With Quote
Old 12-20-2012, 03:02 AM   #39
StraightUp
Registered Users
 
My HF Map location
Join Date: Apr 2012
Location: Canada
Default Awesome!!!

Wow great job!!!
I can't wait to get mine in the mail.
Cheers
StraightUp is offline        Reply With Quote
Old 12-22-2012, 06:27 AM   #40
FPVflyer
Registered Users
Thread Starter Thread Starter
 

Join Date: Dec 2012
Location: Central Europe
Default

Hello peoples!
I will explain the full details (already partly explained by big friend Zee )

Helicopter Frame:
- T-REX 600 PRO 2012 (FBL)
- KDE universal motor mount
- 115T Helidirect main drive gear, straight thoot
- 13T pinion
- CNChelicopter tail control upgrade (http://www.cnchelicopter.com/servlet...600-CNC/Detail) 'cause I wil all bearings
- Spinblades 600 asymmetrical blades (100% more efficient in only standard flight, with weight balance much external in the blades for higher inertia and better autorotation)
- Spinblades asymmetrical tail blades

RC, stabilization and power equipment:
- 3x DS610 on swashplate
- 1x DS650 on tail
- YGE 90HV ESC (too big)
- Gryphon QASAR BEC
- DJI NAZA-H with GPS
- Scorpion HKIII 330kv (700 size, choosed only for lower kv, fit very close to the servos)
- Gens-Ace 12s 5300mah (fit precise at mm!)
- EzUHF long range system with diversity receiver and 2x dipoles antennas

FPV Equipment:
- TBS59 camera (590TVL)
- TBS CORE (for 12s monitoring and camera + vtx power supply)
- FLIR TAU2 640 (thermal camera for search and rescue)
- NGHOBBIES video switcher (more in testing, for FLIR/standard picture switch)
- 2s 2500mah lipo for video (will go down to 1500mah soon)
- MCtronic device for RSSI digital to analog converter
- 2.4ghz video transmitter with SPW antenna from Circular Wireless

Interesting information, yesterday I've done the first LR flight, 22mins in the air, 2km away, and very quiet flight. In hovering it drain 10,5A, keep moving on flight level around 9,5A, descending 3,5A.
Must add more 1amps for all the RC system + FLIR camera, and finally the average flight time will be around 18-20mins

That's all I think, if someone is really interested I can open a thread presenting it, and continue it during his carreer in SAR
FPVflyer is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Electronics Support > Flight Stabilization


Flight Stabilization Flight Stabilization

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com