Fun, Learning, Friendship and Mutual Respect
START  HERE


Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 100 Class Electric Helicopters


100 Class Electric Helicopters 100 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.


Reply
 
Thread Tools Display Modes
Old 01-29-2014, 11:37 PM   #1
Danny TERRA
Registered Users
 

Join Date: Aug 2010
Location: CALIFORNIA
Default Trex 150 Head Speed Problems

My head speed is not getting up as high as it should be. I have tried everything. Before you ask, the first thing I did was set throttle end points. I even bound a friends helicopter to my controller and there's was perfectly fine. I bound mine to their controller and still the problems. I am pulling my hair out about this one. I have had nothing but problems since getting this helicopter. What should 100% flat curve head speed be? Please help!
__________________
Herbie T
Danny TERRA is online now        Reply With Quote
Old 01-29-2014, 11:47 PM   #2
Dylwad
Registered Users
 
Posts: 4,201
 

Join Date: Mar 2007
Location: Phoenix AZ
Default Re: Trex 150 Head Speed Problems

Quote:
Originally Posted by Danny TERRA View Post
My head speed is not getting up as high as it should be. I have tried everything. Before you ask, the first thing I did was set throttle end points. I even bound a friends helicopter to my controller and there's was perfectly fine. I bound mine to their controller and still the problems. I am pulling my hair out about this one. I have had nothing but problems since getting this helicopter. What should 100% flat curve head speed be? Please help!
Should be around 7000 rpm

Have you tried increasing throttle channel travel adjust, just in case?
__________________
Dylan ~ www.AstroidDesigns.com
Dylwad is offline        Reply With Quote
Old 01-29-2014, 11:58 PM   #3
Danny TERRA
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2010
Location: CALIFORNIA
Default

No I haven't. I am using a JR controller. I will try that now. Should I try it at full 150%?
__________________
Herbie T
Danny TERRA is online now        Reply With Quote
Old 01-30-2014, 12:04 AM   #4
Danny TERRA
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2010
Location: CALIFORNIA
Default

I tried it with no success. I have a phone tach which isn't all that accurate, but it's stating about 4900rpm.
__________________
Herbie T
Danny TERRA is online now        Reply With Quote
Old 01-30-2014, 03:47 AM   #5
Thermikflieger007
Registered Users
 

Join Date: Apr 2013
Location: Swisttal
Default

Set your Battery Type to "Auto" ! When you do on "2S" it will have less power...i think this is a failure in software
Thermikflieger007 is offline        Reply With Quote
Old 01-30-2014, 05:53 PM   #6
gabeoravitz
Registered Users
 
Posts: 900
 

Join Date: Apr 2012
Location: San Diego, CA
Default

Holy cow. I knew this thing was screaming, but I didn't realize it was 7000rpms! Did you tach this yourself?
__________________
Team KDE Direct
gabeoravitz is offline        Reply With Quote
Old 01-30-2014, 07:34 PM   #7
Dylwad
Registered Users
 
Posts: 4,201
 

Join Date: Mar 2007
Location: Phoenix AZ
Default

Quote:
Originally Posted by gabeoravitz View Post
Holy cow. I knew this thing was screaming, but I didn't realize it was 7000rpms! Did you tach this yourself?
http://www.helifreak.com/showpost.ph...postcount=2546 confirmed with a tach, 7100 RPM, V1, HP06V2 8200KV 10 tooth

I have had an MCPx up towards 8000RPM
__________________
Dylan ~ www.AstroidDesigns.com
Dylwad is offline        Reply With Quote
Old 01-31-2014, 06:59 AM   #8
Danny TERRA
Registered Users
Thread Starter Thread Starter
 

Join Date: Aug 2010
Location: CALIFORNIA
Default Headspeed problems

Thanks THERMifleger 007 you nailed it.Had it on 2 cell lipo and power was way down.Switched to auto like you suggested and it is great now.THANKS.
__________________
Herbie T
Danny TERRA is online now        Reply With Quote
Old 02-03-2014, 12:37 AM   #9
gabeoravitz
Registered Users
 
Posts: 900
 

Join Date: Apr 2012
Location: San Diego, CA
Default

Quote:
Originally Posted by Dylwad View Post
http://www.helifreak.com/showpost.ph...postcount=2546 confirmed with a tach, 7100 RPM, V1, HP06V2 8200KV 10 tooth

I have had an MCPx up towards 8000RPM
haha i couldn't imagine trying to fly an MCPx at that head speed. That would have to be perfectly, perfectly balanced.
__________________
Team KDE Direct
gabeoravitz is offline        Reply With Quote
Old 02-03-2014, 12:49 AM   #10
Dylwad
Registered Users
 
Posts: 4,201
 

Join Date: Mar 2007
Location: Phoenix AZ
Default Re: Trex 150 Head Speed Problems

Quote:
Originally Posted by gabeoravitz View Post
haha i couldn't imagine trying to fly an MCPx at that head speed. That would have to be perfectly, perfectly balanced.
It gets to the point that moving a 3 mm square piece of tape 3mm on the blade makes a difference lol.
__________________
Dylan ~ www.AstroidDesigns.com
Dylwad is offline        Reply With Quote
Old 02-03-2014, 01:51 AM   #11
gabeoravitz
Registered Users
 
Posts: 900
 

Join Date: Apr 2012
Location: San Diego, CA
Default Trex 150 Head Speed Problems

Quote:
Originally Posted by Dylwad View Post
It gets to the point that moving a 3 mm square piece of tape 3mm on the blade makes a difference lol.

And considering how the mcpx 3-in-1 has almost zero tolerance for vibes at higher headspeeds...yikes!
__________________
Team KDE Direct
gabeoravitz is offline        Reply With Quote
Reply




Unregistered
Go Back   HeliFreak > R/C Helicopter Support > 100 Class Electric Helicopters


100 Class Electric Helicopters 100 Class Electric Helicopters manufactured by Align, Tarot, SYMA, Airhog, Chaos, HK and similar.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Copyright © 2004-2011 - William James - Helifreak.com